H9 X3 Box will not boot from mSD - what can I do?


A friend just ordered a generic S905X3 Box to run CoreELEC.
I promised to help him, since I had many generic AMLogic boxes that all worked perfectly.

It’s a 4GB/64GB 1000MBit S905X3 device called “H9 X3”, according to all the descriptions.

Unfortunately, I cannot get it to boot from mSD!
I have followed the standard steps as I always do and I have tried all these methods as described in the guide:

  • Terminal Emulator
  • Toothpick
  • Menu Button
  • Recovery

The all result in exactly the same thing:
The box is stuck on it’s flashy H9 X3 logo and that’s it.

It boots just fine into Android when I have the mSD removed…

What am I doing wrong, what else can I try?

I tried both these device trees:

  • sm1_s905x3_4gb_1gbit
  • sm1_s905x3_4gb_1gbit_slowsdio

I appreciate any help!
Thanks in advance!

Try the sm1_s905x3_4gb and sm1_s905x3_2gb DTBs.
Also, try a different SD card, try booting from a USB stick.

I might be stupid for ruling that out… :roll_eyes:
Thank you!
I had already tried both USB ports without success, but the 2GB DTB actually worked right away!

So, he got scammed. :frowning:

The box is actually a 2GB/32GB/100MBit.
Let’s hope he gets a full refund or better the correctly specced box quickly.

Alright, things are getting really strange now.
Apparently, he did not get scammed after all.

Have a look at what Android tells me about the box:

How is that possible? If the box actually is 4GB/64GB, why did only the 2GB DTB work and CE tells me this:?

It´s fake ram.

Unbelievable… The world we live in. :wink:

He will send it back and order a well-known X96 Air instead.
Let’s hope this one is OK.

X96 Air arrived - works perfectly. :slight_smile:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.