H96 Max - S905x2 CoreElec Instalation ERROR

I have installed successfully CoreElect on a T95N with the S905

But now, im trying to install on a H96 Max with the S905X2

I used the LibreELEC.USB-SD.Creator.Win32 to install CoreELEC-Amlogic-ng.arm-9.2.1-Generic.img
and i utilized the g12a_s905x2_4g and renamed it to dtb.img

I boot into android, and run the UPDATE and BACKUP app. I select a .zip file, and click the UPDATE button, which is what i did succesfully on the T95N and it reboot the system, but instead of booting into CoreElec, I get a picture of an android robot with the word “Error” It then reboots back into android.

I have tried both USB slots with the same result

What the heck am i missing?
Thank YOU

Number 1, thank you for moving the post to the right thread. I realized that after i posted it.

Secondly, i got it to work. I had to use the toothpick method. That got it to work properly. The update/backup that worked with my T95N worked like a charm, but not with this device.

I LOVE what CoreElec is doing and give KUDOS to EVERYONE who is involved with this project.

1 Like