Hang when accessing folders of images

I have a few Odroid N2s with Coreelec on them. Wonderful machines & very stable in general. Thanks for all your excellent work.

I do have one persistent and repeatable issue though.

I have noticed these machines hang when I access folders of images - speicifcally if there are any new image in the folder (in the Kodi pictures section), or if the folder has not been visited before. The hang will last up to about a minute or more, and the system will be basically non responsive to remote input during that time (will occasionally respond after several seconds but often not at all).

The images are all standard JPG images (all sized to fit 1920 by 1080 - photos of family/friend/nature exported from Lightroom). Folders might have anywhere from 20 to 150 images, but the hang seems to happen if e.g. there are just 20 or so new images added to folder.

The images are accessed over NFS which is working perfectly for all other things, videos, music etc.

Other systems on the same network (Kodi on Windows, or NUCs with Libreelec) - do not experience these delays at all. On those there is the initial loading dialogue for folders with lots of images and you can sometimes outrun the thumbnail creation if you move very quickly about but these systems recover almost instantly from that).

Initially I am trying to isolate the issue and find our whether others are experiencing similar? I have not yet dug into logs or anything, but my gut feeling is the thumbnail creation or reading of image metadata is choking the system somehow…

Thanks for any thoughts/help!

I have experienced similar on my N2. I think its a network issue as my N2 tends to choke if its scraping or loading lots of metadata.


I’ve had the same issue before and tracked it down to being cause by Kodi hanging when generating the thumbnails when you first enter a folder of images. It can be solved to a degree by going to Settings->Media->Pictures and turning off Automatically generate thumbnails.

1 Like

Hmmm, I don’t really want to lose thumbnails.

Feels like the N2 should easily have enough CPU grunt (and network bandwidth, is gigabit ethernet after all) - to cope with this.

I am thinking there some sort of inefficient bit of code that causes this process to be a lot more expensive than it should be, perhaps?

If you turn off auto thumbnails, does that mean you just get blank boxes??

This isn’t just an N2 issue and has nothing to do with network bandwidth. I’ve had the same issue on other Kodi devices, and it seems to be random sometimes it works and sometimes it doesn’t. I thinks it’s just a Kodi bug.

If you turn off auto generate thumbs, then you don’t get thumbnails and ned to bring up the context menu and select regenerate thumbnails to generate them.

Hmm, I’ve never previously experienced the issue on LibreElec machines (mainly fairly basic NUCs or AMD based PCs)…but that said I just tried on my PC and there are definitely some hiccups there too.

Must be a relatively new issue, though, as for years I’ve not had this issue, only just recently noticing in the last few months, coincidentally as we moved to N2s with CoreElec.

Will go raise it over on the Kodi forums…thanks

Install CoreELEC on internal memory or an external USB disk drive. I think your problem is in the flash memory.

Also keep an eye on running addons and delete malicious.

This isn’t a new issue. I have experienced the same result in Odroid-C2 with previous CoreELEC versions as well as with all latest CoreELEC on N2.
I think this is a kind of bug in Kodi.

Pretty sure it’s not my flash memory, as nothing else is affected. I have zero dodgy/malicious addons, of that I am sure, I really only use Kodi for local playback.

I took it up here - and found a fix in Matrix that appears to help, although it is not conclusive as I am testing on a full Windows PC and not, therefore, equivalent hardware. But I did realise I was originally wrong and seeing hangs on Windows too, albeit shorter ones.

…so I suspect this may already be a solved issue in Kodi Matrix, in summary. I’ll certainly be testing it once CE betas for Matrix appear…

Coming very soon.
Hope Matrix does indeed fix this.


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.