Has anything related to IR or bl301 changed in CE20?

Hello. First of all, let me say that I’m using EmuELEC, not CoreELEC. Well, I actually use both, but my issue is related to EmuELEC. I know I should not ask for help about EE here, but this is more a question about CE, specifically about CE 20. Let me explain.

When I was using EE 4.3 (version with CE 19 as base), I was able to inject bl301 and put the rc_maps.cfg and rc_keymaps config files for my remote, and that worked.

Now EE 4.4 is out, and it’s based on CE 20. Well, now my remote does not work when the system is up and running (I still can power on when the device is off with the remote, but can’t power it off anymore). I tried to inject bl301 and now it does NOT work, it returns segmentation fault. And not even with this command, ir-keytable -p NEC,RC-5,RC-6,JVC,SONY -t, my remote is recognized, like no keys were pressed at all. I’ve been talking with the EE developer, and he told me that he has not touched, nor has he ever touched, anything related to remotes or bl301.

So, my guess right now is that something may have changed on CE 20. Either that or EE has broken something, unintentionally.

If it is the first one, please tell me where the issue could be, or where to look for. If it is the second, can you guys think of any command or file to check/try/whatever?

Here’s a log of the system: http://ix.io/3Tlg

My device is a GT King PRO

If an admin think this topic should be on a CE 20 discussion page, please move it.

Thanks to all in advance!