HDMI ARC problems?


Describe the bug


So I never had issues with my devices until now. So what happen was I tried to watch Netflix from my TV using ARC to return the Dolby audio back to my Yamaha receiver. That has always worked without a problem.

I have a S905 device with coreelec and what I noticed was even with the device OFF, it seems the HDMI port is being hold by the device somehow. If I unplug the device for power or remove the HDMI cable it releases the port and the ARC starts to work again.

If I put the cable back or the power (without actually turn the device on) it will start to hold the port again and ARC stops working once more.

Not sure if this is a new problem or was already discussed.

To Reproduce


1 - With the HDMI from the S905 device connected to the receiver, turn the TV on netflix and try to use ARC back to the HT. It doesn’t work for me.
2 - Remove HDMI cable from S905, re-start the tv and all is working again.

Is this related to these options by any chance?

Keep audio device alive + Send low volume noise?

Should I keep those options off?

Very possible. You shouldn’t need them to be on, unless there are other problems with audio.

This is a problem with U-Boot. There is no fix for this.

1 Like

So the only fix is to remove the device from the outlet like I am doing.

Just out of curiosity could you explain what is the UBoot issue?