HDR2SDR option not working in 9.2.2 (always on)

use the audio video output, av output.

I’m curious as to what advantage there is to turning the feature off.

Because with this feature is set to ON (and it is now ALWAYS ON since February 2020, independent of the switch in the CE-settings) with my N2 (S922X, CE 9.2.2) there are artifacts/color banding in HDR videos, see picture 1.

The same screenshot on my old EgoIggo S905X-box shows no artifacts/banding (picture 2) and brighter colors.

-> HDR2SDR on N2/S922X is faulty (artifacts, picture too dark).

If HDR2SDR can be switched off then there are no artifacts with N2/S922X. Of course colors are then more pale and I have to correct them on my TV.

Thanks for the explanation.

Would it be acceptable for you to be able to turn HDR2SDR off if it also meant that the OSD was pale as well during playback of HDR content?

I think this would be better than nothing, let’s give a try.

But please consider this faulty behaviour I described a few month ago when HDR2SDR=off:

Especially paragraph 3:
When a BT.709 video is played AFTER a BT.2020 video was played with HDR2SDR=off, the colors
of the BT.709 are wrong/much oversaturated.

This is far from being an optimal solution, but should hopefully provide you with the desired effect.


1 Like

Thanks @cdu13a, I tested and the devel version works as expected. The switch HDR2SDR works now.

A BT.2020 video is now shown as BT.2020nc in player process info.
To have a good picture I defined different TV settings for BT.709 and BT.2020 videos.
And the not-switching-back-to-bt.709-correctly-after-viewing-bt.2020-error is also no longer present.

The fact, that the OSD is pale during playback of a BT.2020 video doesn’t matter for me.
If the video is stopped and the normal GUI appears again, colors are correct again.

Will this change be included in the next nightly?

Thnx again!

I just pushed the patches, so this should be in the next nightly build.

good news!

With the latest nightly build and after small adjustments of the TV with HDRtoSDR off, everything seems fine on my LG TV and Vim3. The colors look natural. The sky is not too blue, the tomatoes are not too red, the grass is not too green or too yellow if it is a little withered.

Thanks @cdu13a, good job!

hi, This is new function release with kernel 4.9?
“HDR to SDR tonemapping for those watching HDR content on SDR only displays”

I’m going to chime in here, sorry if it seems as if I’m rocking the boat, but can we have a simple on/off option in the CE settings as video is terrible on older boxes. I’ve been posting a lot lately trying to get a NEXBOX A95X and a Beelink Mini MX to run correctly so I can have the option of playing 10bit files. The whole experience has been so bad that I’ve gone back to my MXQ’s.

The install of CE etc was pretty simple but trying to get decent video playback has been agony! It’s not just the judders, which I’m famously known for moaning about even back in the Libreelec dayz, it’s now really blurry and fuzzy video playback!! I think the judder which happens from time-to-time is something we generally accept but it has gotten worse possibly because of the HDR.

For the record the video playback on my old MXQ’s is almost as good as Blu-Ray and is very good although 10bit playback would be nice. Yes the S805 can’t do 10bit hence why I bought to cheap second-hand S905 boxes and started my journey, err, nightmare! The simple resolution is to give people the option of turning HDR off. Maybe it’s not even the HDR, perhaps old S905/S905X boxes are just not good enough to run CE yet they are listed so what gives?

If it wasn’t for the fact I experienced the same blurry crappy video playback on two S905/X boxes I would have just accepted that the box was crap but two suggests that many boxes may have crappy playback!? So is it just me or do others feel that something is wrong with video playback on CE?

Not rocking the boat I just wondering if I’m so unlucky as to have two really crap boxes, the Beelink and the NEXBOX?!!

1 Like

You can’t turn HDR off, it’s part of the video file.
Devices that don’t support HDR, like the S905, can’t do anything with the HDR10 metadata, and you’ll just get a washed out image.
Newer devices, starting with S905X, support HDR. To play HDR files and have them look like they’re supposed to requires an HDR display. If your display is not HDR-capable, then you will have to either use tone-mapping (HDR2SDR) and let the box try and adjust the colors and brightness of the video to better fit the SDR video format or disable tone-mapping and watch it in washed out mode - like on S905.
Now, I’m not 100% sure this feature is even available in our 3.14 kernel, for the older devices (S905*/S912 range)

1 Like

The HDR2SDR- and SDR2HDR-option is not available in the CE version for S905* (kernel 3.14).
HDR2SDR is active by default and not changeable via GUI-settings.
These options are only in the NG-versions available in the GUI.

1 Like

How is this suppose to work? I have both a S905x2 and S905x3 with CE latest version. Im playing a 1080p HEVC HDR videofile in an old LG fullhd SDR tv and it is awfully dark. I have HDR->SDR and SDR->HDR options enabled in the GUI. Any tip?

Set SDR to HDR off and HDR to SDR on.
If it’s too dark, I don’t think there’s much you can do. Make sure that your TV is set to maximum backlight setting.

Would it be possible to implement the HDR>SDR tone mapping algorithms currently in the Windows version of Kodi for D3D and OpenGL, into the CoreELEC/ARM/OpenGSEL version?

These would be the Hable and ACES Filmic algorithms. Running on Windows, I see no noticeable increase in CPU or GPU usage when activated, but the tone mapping is excellent, far superior to the tonemapping CE seems to be using now. No artifacts, no washed out colors. With these algorithms, HDR content on my SDR display is very close to the native SDR version and comparable if not superior to the tonemapping in Plex.

Not possible.