Help please 128GB EMMC V0.5 for N2

I’ve acquired one of these cards and have learnt that:

  1. My EMMC to Micro SD converter wont work with it. It only works with V0.4.
  2. I have to buy a ODROID USB3.0 eMMC Module Reader / Writer [77748] if I want to use etcher with it
  3. The Petitboot option for installing to this EMMC version doesn’t work for it.

Before I spend on option 2, could someone tell me if CoreELEC will run on this version of EMMC. I’ve looked in lots of places and can’t seem to find an answer.

Thanks to anyone who replies.

Have you checked here?

Thanks for your reply @Betatester. Yes, I’d referred to this before posting. I’d tried to do the USD and SSH install but it wouldn’t work when I had the 128gb v0.5 EMMC card in. There was no option in Petitboot to boot the CoreELEC from the SD card. If I powered down and replaced the card with a 16GB v0.4 EMMC then I did get the option.

I’m asking the community here to see if anyone has CoreELEC running from EMMC on a V0.5 EMMC. If so, I’ll happily buy one of the readers I described in 2 in my original post.

Well, I have 2 “small” eMMC cards, (only 16GB), one is v0.4 and other v0.5. They both work perfectly and I flash them both via USB3.0 to eMMC adapter (Rev 0.1). Haven’t seen any different behaviour from either. Cannot guaranty that it will also work with an 128GB though…

eMMC module compatibility reference: Hardkernel Wiki

@sonofdibnah

You won’t find your answer on the wiki.

Step #1 is that you want to update petitboot to most recent version.

to do this boot to petitboot then exit to command line and run

pb-update

(or you can also use an uSD card to update petitboot.
by downloading http://ppa.linuxfactory.or.kr/images/petitboot/odroidn2/spiboot-20220221.img
renaming it to spiboot.img and copying it to a fat formatted uSD card.
then boot the n2 with boot select switch set to spi and that uSD card inserted.)

Step #2 follow method #2 found here CoreELEC - Ways to install CoreELEC to eMMC without the eMMC module writer. - ODROID

ps. I would still recommend the USB 3.0 eMMC writer since it is handy to have, however the above should allow you to get CoreELEC installed the way you want, and you can wait on getting an eMMC writer until the next time you are ordering something else from Hardkernel.

Sorry, but I see a typo, isn’t sptboot supposed to be spiboot.img? Am I wrong ?:thinking:

1 Like

It was, thanks.

1 Like

Thanks to all and especially @cdu13a. The instructions worked like a charm and I was able to flash CoreELEC over the Home Assistant that was installed.

The USB3 EMMC writers are expensive if bought alone, so I’m very grateful for the steer.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.