Homatics Box R 4K Plus

No, you need to run uname -a


i ended up returning the box… in android i could only get 350 to 400 mbp/s while some1 that also has this box got 950±.

I think that is the same generic SEI Robotics remote for the Walmart ONN and I can pair/connect it but I don’t see it with cat /proc/bus/input/devices on ng or ne with S905x4 or on the Beelink GT King II.

I do see it in an adb shell, so it might be a BT issue in CE

I: Bus=0005 Vendor=0957 Product=0005 Version=0111
N: Name="Onn-Remote Consumer Control"
P: Phys=
S: Sysfs=/devices/virtual/misc/uhid/0005:0957:0005.0003/input/input9
U: Uniq=74:9e:a5:4b:ec:36
H: Handlers=event9 
B: EV=1f
B: KEY=300ff 0 0 0 0 483ffff 17aff32d bfd44446 0 0 1 130ff3 8b17c000 677bfa d9415fed 9ed680 4400 0 10000002
B: REL=1040
B: ABS=1 0
B: MSC=10


Non working ethernet

Extracted the dtb.


Did you try sc2_s905x4_4g_1gbit?

Please boot Android and run cat /proc/device-tree/amlogic-dt-id and /or make a Android dmesg log.
There are 4 DTBs in the Android dump so I would need to know which one is used for your device.

yes with the sc2_s905x4_4g_1gbit I get a weird ip address that starts with 169.

I get permission denied with android commands

Error when I enable ethernet in coreelec settings


Anyway other way to get this information?

Maybe it uses same, new chip like the Ugoos X4Q. We will see…

1 Like

When I installed the CE-ne 20 nightly, it can worked with the buzztv dtb… matrix works for me with the generic. Strange…

1 Like

Confirmed working

What confirned? Works as mine? In matrix or in nexus?

Yes works with buzztv dtb. Thanks

Ok, but why in yours not working with the generic in matrix. And why in nexus works just with buzztv dtb? …x-files…

So something about the pins is maybe different but same as BuzzTV?

With BuzzTV DTB: dmesg | paste

1 Like


I only tried with nexus.

http://ix.io/4lch Nexus buzztv dtb

http://ix.io/4lcj Matrix generic dtb