Homatics Box R 4K Plus

@rome1931 the device is not come up again for remote session.

Please check if Kodi is started.

If you please share:


no ethernet


But the dmesg shows it’s up, can you also share the current dtb.img on the device?

I get the weird ip address, tmate was still on but you could not connect.


Will you need tmate again?

The problem I found is with a cable limited to 100MB I get usable ip address and with 1gb cable I get weird ip address. 1gb eth connection with buzz tv and ugoos am7 dtb.

The changes I have made only apply on the image I flashed on the device.
Also they only do affect if a DTB is used end on *1gibt. So other DTBs aren’t adjusted for your device.

On fresh install it would be no eth on first boot. After kodi is started once and device is rebooted eth should work. So if it still does not work with sc2_s905x4_4g_1gbit I will need to take a look again.

So what is now the status?

I checked your dtb.img and it was not changed. Need to check why not.

@rome1931 it should work now.

Please run these SSH commands step by step to clean out your device to “standard”:

rm .config/autostart.sh
rm do_reboot
rm /flash/dtb.*
cp /flash/device_trees/sc2_s905x4_4g_1gbit.dtb /flash/dtb.img
cd .update
megadl https://mega.nz/file/HSJRzRIK#tVyQzCEdh_GAyMbudchUuzVZOzDZ7OOutzVUS2lAWqw

It should than run a update and on first boot Kodi should show a pop up that you will need to reboot the device. Do this once and ethernet should work.

Please do these steps and confirm it’s working, thx!

no Ethernet after after commands

this information just help nothing.
Any log? tmate over wlan?

tmate activated



no, it’s not online and dmesg shows again eth is up with 1gbit

eth is up with unusable ip address, just rebooted for tmate restart.

ok, the eth chip is not coming online so the phy id can not be read at all on boot.
so a manual user interaction will be needed in CE settings to be able to choose this chip

@rome1931 I rebooted the device and ethernet should be working now?
but tmate is offline again

Yes eth is working, Thanks

Try tmate now

No, it’s not coming online
please try again. I have almost a new test version available

I restarted tmate

ok, updating soon.

when the update is finished please enter CE settings - hardware and change Motorcomm option to assembled. After a reboot eth should be working.

1 Like

Confirmed setting works, Thanks