How to disable CE auto-update over SSH session?

Could anyone help me to disable CE auto-update feature over an SSH session? I have tried to look into different config files, in particular into ~/.kodi/userdata/addon_data/service.coreelec.settings/oe_settings.xml
or was trying to grep it in ~/.kodi/userdata folder with
grep update $(find ~/.kodi/userdata -name "*.xml") but did not find anything remotely close.

Is there a config file, which can be modified to turn it off? Or any other means doable via an SSH session?

I thought it was that file. There’s a setting called <AutoUpdate>auto</AutoUpdate> which can be set to manual.

Haven’t verified it though as I auto-update.

Well, my oe_settings.xml looks like this:

<?xml version="1.0" ?>
<coreelec>
        <addon_config/>
        <settings>
                <system>
                        <wizard_completed>True</wizard_completed>
                </system>
                <connman>
                        <wizard_completed>True</wizard_completed>
                </connman>
                <services>
                        <wizard_completed>True</wizard_completed>
                </services>
                <about>
                        <wizard_completed>True</wizard_completed>
                </about>
                <coreelec>
                        <wizard_completed>True</wizard_completed>
                </coreelec>
        </settings>
</coreelec>

so I am bit confused, how to put the AutoUpdate item in there?

Well so am I. My looks like this

<?xml version="1.0" ?>
<coreelec>
        <addon_config/>
        <settings>
                <system>
                        <wizard_completed>True</wizard_completed>
                        <hostname>mecool</hostname>
                        <KeyboardLayout1>fi-latin1</KeyboardLayout1>
                        <AutoUpdate>auto</AutoUpdate>
                </system>
                <connman>
                        <wizard_completed>True</wizard_completed>
                </connman>
                <services>
                        <wizard_completed>True</wizard_completed>
                </services>
                <about>
                        <wizard_completed>True</wizard_completed>
                </about>
                <coreelec>
                        <wizard_completed>True</wizard_completed>
                </coreelec>
        </settings>
</coreelec>

Are you on 8.95.1? Do you have access to the GUI and can you see the auto-update settings under Settings -> CoreELEC? If you change it via the GUI does it add the section which you are missing?

1 Like

Eeee, no, no, and no.
I am on 8.95.0 and I am trying to avoid 8.95.1 because it breaks the DVB-T tuner support on my Minix Neo U9-H. I cannot access the box physically, neither has anyone who could do it for me :expressionless:
Do you think this is new in 8.95.1?

I’ve been using CE since the first version but unfortunately I can’t recall when it popped up. I can’t see it mentioned in the change log for 8.95.1 either.
It’s probably better to wait 'til some dev can confirm if it either way.

I have just tested it by adding <AutoUpdate>manual</AutoUpdate> into <system> section according to your file and it seemed stopped the automatic download of the 8.95.1 tarball. So this looks like this is it. Why it is not in the config file from beginning I do not know.

Thanks! @Rascal