How to fix an incorrect upgrade

So I did something stupid, the 20190826 ng tar file is missing from and not realizing this I upgraded my N2 using the standard nightly and now it just freezes at the CoreELEC logo screen :frowning:

So I pulled out the eMMC from my N2 and from an older ng nightly copied the SYSTEM and KERNEL files back over to the eMMC as well as the N2 dtb however my N2 still wont boot :frowning: I’m guessing this is a uboot problem, is there anyway to fix this without having to do a complete reinstall.

To replace system kernel and dtb file usually is enough
Try also some old build…

I thought that as well, just replace the system, kernel and dtb and it should work.

I’ve just tried again with the latest nightly:- CoreELEC-Amlogic-ng.arm-9.1-nightly_20190827.tar

Copied SYSTEM, KERNEL and I’ve tried both dtb’s, Odroid_N2_dtb.img and the one out of the device_trees directory, g12b_s922x_odroid_n2.dtb. Renaming them both to dtb.img but it still wont boot, just gets stuck at the CoreELEC boot logo.

No worries, I’ve backed up the entire storage partition so a full reinstall is pretty easy.