How to run CoreElec on internal memory eMMC on NG boxes (S905X2, S922X) having full operating Android system too

Sorry it’s a little ot, but
@Emerson or anyone else, do you have a proper remote.conf for the x96 max?

remote.conf, vfd.conf and other useful tools for X96 Max:
link
included remote.conf, transmission and ext4 kernel are Emerson’s(Csicsóka on Prohardver) work, thanks to him

1 Like

This one worked for me - CoreELEC 9.0.x Remote files

1 Like

How to update CoreELEC on internal memory eMMC on NG boxes

Only for this system!!!

The upgrade process is the same as the system running on the original SD.
The downloaded update.tar file should be in the /storage/.update directory.
Only .tar format supported, no img.and img.gz.
It is also possible to run the update-eemsystem command on SSH.
update-eemcystem kernel only updates kernel.
The update works from stable to nightly nightly to nightly nightly to stable.

The installer does the following:

  • Download emmc.tar-gz for the platform.
  • Unpack and copy system files into place.
  • Replaces the kernel, saves the original.

To download and run the installer:

 wget http://www.emerson.nhely.hu/wp-content/uploads/2019/11/emmc_update.sh_.gz -O /storage/emmc_update.sh.gz 

gunzip emmc_update.sh.gz

chmod +x emmc_update.sh

mount -n --bind /var/media/COREELEC /flash

./emmc_update.sh

How the update process works (update-eemcystem):

  • Unpack CoreELEC-Amlogic-xyz .tar file.
  • SOC tipe check (NG or Old)
  • Kernel image extraction init replacement in ramdisk. (unpackbootimg)
  • Kernel image assembly, copying into place. (mkbootimg)
  • Backing up kernel.img to kernel.img.old
  • Upgrading rootfs with rsync except for exclude list. (/usr/lib/coreelec/exclude.lst)
  • dtb, aml_autoscrypt, etc. update with /usr/share/bootloader/update.sh.
  • Reboot

Hi, can I run coreelec in eMMC internal memory on the Beelink GT Mini-A? Android TV is installed

Please read this:

Thanks, I have read this and my device is not supported. Therefore, I ask in this post

You can read instruction fully and at the end to find how to install on unsupported device.

1 Like

Yes but I read somewhere that could be a problem because android tv is installed. Does anyone have experience?

ceemmc working X96 Max not work A 95X Max
This system works on both boxes.
I have no information on Android TV os.

Does it start by default from sd card after reboot on A95X Max?
If no then it possible you need to install or start CE again via reset button on sd card.
Also check that aml_autoscript file present on sd card…

New nightly SD installation works fine.
ceemmc single mode black screen at start of boot.
in dual mode only the android starts. aml_autoscript okay.

Thanks for the info

Thank you Emerson
Just tested on X96Max 4/64 and work rly great with latest Xannytech Android TV V311P firmware , very responsive and fast Coreelec

I don’t know how it installs to the internal memory, but after removing the sd card
CoreELEC does not start, the partition is done and that’s it
it doesn’t work without a memory card


If you don’t have A95X boxes…

i don’t have, i have gt mini

CoreELEC: ~ # ceemmc -h
-sh: ceemmc: not found
CoreELEC: ~ #

You need to use latest nightly as minimum for this feature.

This system uses the SD card to boot.

Thanks for the answer
I checked nightly and has a disadvantage, constantly displaying update.
This is not very pleasant