I can't boot from usb pen

I just got my new N2 and I tried to install coreelec on an usb pen.
I used etcher to flash the stable version.
When I tried to boot selecting the coreelec image from the system prompt, I got this error:

cannot determine the file type of /usr/var/petitboot/mnt/dev/sda1/kernel.img

I tried to flash the usb pen via Rufus with the same result.
Any clues?

N2 does not boot (at present) from USB stick like from uSD card.
You need to use new version of Petitboot in order to boot CE from USB, and to position the switch to SPI position

Thanks for the reply.
I found this guide to update the petitboot:
I copied the latest img (renamed in spiboot.img) on my sd card, but when I powered on the N2 it booted the system on the sdcard, without updating the petitboot on the spi image.

I was doing it wrong.
The corrected procedure was:

  1. format the sd card;
  2. copy the petitboot image
  3. plug the card in the N" with switch on spi
  4. power on the N2

The update process started

Now the usb pen boot fine, but it hangs on booting:
Error in prepare_sysroot: mount_common: Could not mount /dev/SYSTEM

How big is your USB pen drive ? Are you using proper image file ? Burn your fresh formated (to Fat32) USB pen drive with proper new image using “BalenaEtcher”…

16gb and I did what you suggested

Your problem is not booting from USB, but installing CE on an USB pen drive…
Can you install and boot CE from uSD card?

Yes, from uSD card N2 boots fine.
From usb pen it boots, I can see the coreelec logo but at some point it hangs.

OK, so you have a working version on uSD and presumably an uSDtoUSB adapter. If so, what happens when you plug your uSD card in USB adapter and then use it for booting from USB port? That is the way I boot my N2, never tried to run the installation directly from USB drive…

You’re right.
From the usb adapter my N2 boots fine.
I’m a little disappointed because I’d like to make tests (nightly builds and addons) on my usb pens (I have lots of usb pens and just one uSD card).
By the way, thanks for your help, at least I learned how to update petitboot, which maybe in the near future will suits my needs.

Try cloning your uSD installation to the same size USB pen drive. It might work; cannot try it myself, as my N2 is not with me on summer holidays.
For cloning I use Win32 DiskImager, which does the job very good if both media are same size…

I will try.
Thanks a lot