Instances of DialogNotification not being destroyed

I have a weird bug in Kodi 18.9 that I’m trying to track down. Basically, after a toast notification is created, it is never destroyed.

In terms of the Kodi log, I get “Window Init (DialogNotification.xml)”, but no “Windows Deinit (DialogNotification.xml)”.

This issue is not present in the Kodi builds for Ubuntu X86-64. It only occurs for LibreElec and CoreElec. The LibreElec system I have tested was X86-64, so this isn’t an Arm specific issue.

Any ideas as to what LibreElec patch might be causing it?

I can also confirm I ran into this issue quite a few times running 18.9 and always had to restart Kodi to clear the issue.

So far running Kodi 19 Matrix I haven’t seen the issue yet.

I’m trying to remember at what release I noticed that problem. It had started before 18.9. I had just assumed it was Kodi Pull 17782 (so 18.7) and was going to see if backporting Kodi Pull 18776 would fix it… until I discovered my Ubuntu system didn’t show this problem.

The mystery has been solved. Turns out it is a bug in Kodi, not LibreElec or CoreElec. It is a bug in smartredraw.

Edit :: Now that I figured out the problem, turns out it is an open issue Kodi Issue #15354

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice