Jerky playback with some H265 1080p movies

My Odroid N2 with CoreElec plays jerky some 1080p HEVC/H265 content when using hardware decoder. If I switch to software decoder playing is smooth.

Here is a sample. It’s the small animation from Universal logo appearing from behind the Earth.

I am playing this up scaled to a 4K TV (3840x2160). If you look carefully, there is a “rush” moment when letter N appears (approx 00:11), and a slight pause when the letter U is about to reach left of the screen (approx 00:13)
As I said, I don’t see this behavior when choosing software decoder - everything smooth.

I updated to 9.2.6 and behaviour remains the same.

Did you try a clean install yet?

I tried your sample on Windows 10 and it does not play fine. So it looks a wrong encoded media file.

I see this jerk on my box too.
But this video is stuttering on my Mac and Windows 10 too, so it’s possible some bad encoded video

I am baffled by the fact that the software decoder works fine. Shouldn’t the hardware one be working as well, leveraging the capabilities of the chip ?

The sample plays fine on my Windows 10 (Skylake cpu) with SMPlayer and also on my phone Huawei Mate 10 with MXPlayer Pro using HW+ decoder.

I had fixed 4K and refresh rate 60Hz because initially my N2 was not switching the display resolution and refresh smoothly on the TV.
Things have improved, I have whitelisted the good resolutions, and enabled the settings option to have it switch, to eliminate up scaling (better to have it done by TV) and judder.

The video plays a little smoother now, so there was some judder, but still the slowing and subsequent rushing when letter N appears, is still present.

I don’t think this will ever be solved with the actual mentality (“it’s them, not us !”), but I will leave here an interesting story for inspiration :slight_smile:

I’m sorry if you have a bad experience with CoreELEC. You should reflect on the story you posted. Maybe you would understand how many were involved in tracking that bug, and that it was their job to do it, not a hobby that they do in their free time.

You say it’s a hobby, this means you enjoy doing it. If writing code is enjoyable, why finding the bug in your own code is not so enjoyable ? My story shows the bug investigation process being enjoyable even if it took two weeks (detailed in the comments)

And besides, where is your craftsman pride to deliver something without defects ?

Dissappointed not so much in CoreElec as in mentality. Ignoring bugs and saying they are isolated cased will not make them disappear. I provided a sample to easily reproduce it and also a clue that the software decoder works. That is all I can do at this moment. I am a database developer not a real-time/system developer.

Maybe You are a little bit wrong ?
I´m using N2 a long time running CE
Never play around with whitelist settings like You.
My N2 is switching the display resolution and refresh smoothly on my TV.

You’re clearly out of touch with what’s done here. Everyday bugs are tracked and taken care of. We can only fix what we can reproduce and there’s only so much that can be done. I really don’t know what you expect to achieve when you attack this Team. You’re free to do what you wish, to use or not to use CE. We have 20000+ active users. How many you see here with the bug you report?

The question is : can you play the attached sample smoothly with HW decoder ?

At least one other user here had this bug reproduced. Also I reported it first on Odroid forum where another user had reproduce it.

If it can’t be reproduced generally, why not say so in the first place ?

Let me run your sample through various devices today at the end of the day. I’ll report back.

This file is wrong encoded, like a lot of other files.

I´m out here

As I said earlier it could by crappy encoded file.
HW decoder code is Amlogic code and it’s not fully available for change. And not all issues could be easy found and fixed…
If it stuck very rare then it could be some video pattern that probably will be fixed by Amlogic in the future.

How can I see exactly what is wrong with the encoding ? Or how can I be sure I choose the right settings if I choose to re-encode ?

I fixed it with a simple remux with mkvmerge. Your reencode is just bad. Remux takes a few seconds only.

1 Like

Will try that, thanks !

I do see a small hiccup at 0:11. Remuxing did not fix it. Plays fine on Intel and nvidia.

1 Like

Indeed the hiccup remains, unfortunately :frowning:
I used command

mkvmerge -d 0 -A -S -o <temp.file.mkv> <original.file.mp4>

About | FAQ | Terms of Service | Privacy Policy | Legal Notice