K1 plus - remote control


#1

Hi, i have had k1 plus with internal instalation of libreelec and i decided to upgrade it to CoreELEC 8.95.6 like my K1 Pro. After upgrading, remote control has works fine, but when i restored backup from K1 Pro (i want to have all my addons, configs etc.) RC stoped working. I’d tried to do everthing i know, but alwas have a same bug:
when i use SSH and type
ir-keytable -t
i’ve this responde:
No devices found
or
ir-keytable -a /storage/.config/rc_maps.cfg -s rc0
No devices found
its seems like somethings wrogs happend with IR module?
I changed dtb.img with one more time upgrade, but it didn’t help. Any suggest?


#2

You need to use the correct DTB from CE.


#3

Internal installation has no CE support, nor does restoring an LE backup to a CE build.
Before tying up the devs (who are actually quite busy) with the same old issues that crop up by not following recommended procedures, try with the CE bulid installed to SD / USB and manually configuring your CE build (just to confirm that your problems are not self-inflicted). :thinking:


#4

Your using an old DTB as @TheCoolest pointed out.


#5

I have a similar issue but I am using Coreelec from SD-Card.

I did a fresh installation (8.95.6) from scratch using the correct dtb (gxbb_p200_k1_plus.dtb).

At the first start the remote was not working so I had to run the following: echo “meson-ir * mecool” > /storage/.config/rc_maps.cfg

Now the K1 plus remote is working but certain buttons are not right.
For example when I press home I don’t get back to the homescreen,

I tried to rearrange with keymap editor but it doesn’t recognize some buttons (home, dtv).


#6

Just for information. I found the solution for my problem using this thread: