KEY_CONFIG not working

I have minix neo u9-h. I added this to the file in rc_keymaps

This doesn’t work. The 0x112 command is working, if I add something else like KEY_MENU, it works.

The problem is with KEY_CONFIG, it seems CoreELEC 9 does not execute it.

Even when I add the Keymap Editor addon, it does not register under it. Any ideas? Could you please try KEY_CONFIG under CoreELEC 9?

I’ve noticed this myself, it’s on my list of things to look at.

Thank you. Please look closer. It is not just KEY_CONFIG. It’s many more. For example KEY_I also doesn’t register.

If you have many more examples then please post them.

I only tested these 2 but probably it’s the same one bug that is causing this. Probably when one is corrected, the rest should work too.

No that is not how it works, some key functions have changed ie KEY_HOME is now KEY_HOMEPAGE, some of these we automatically remap at boot time so the user does not have to reconfigure their config.

We are more than happy to try and help you but please do not make false statements in the future.

I have made no false statements at all. In fact, I have made no statements at all. You please learn to be respectful in the future. Good day.

I think Adam was referring to this “it’s many more”, when you only tested and confirmed two.
Anyway, let’s try to calm down a bit and solve this damn problem.
If you know about more buttons not working properly, please post them here.
Because every key needs to be mapped manually, it can only be fixed with a complete set of non-working keys.

Exactly @relkai

If your going to say something is broken or doesn’t work then at least test it first instead of wasting our time.

I just installed CoreELEC 9.0.2.

KEY_CONFIG still not registering. Any progress on this?

I have tried both methods with
1- remote.conf
2- rc_maps.cfg + corresponding u9.txt

Both give the same results.

It was removed in Leia by the Kodi team here.

KEY_FAV never seems to register even when using Keymap editor.


1 Like

Thanks for the link. Where I have to look at? Is it LinuxInputDevices.cpp? When I look inside it, it still has
KEY_CONFIG at line 270.

Does KEY_PLAY work for you? That also doesn’t work.

KEY_PLAY play works for me.
The “SAT” key doesn’t accept any function.

I always believed that this was something to do with LIRC grabbing certain key presses and not passing them on.


1 Like

I can read all the commands that my remotes send when I type these with ssh

systemctl stop kodi
systemctl stop eventlircd
ir-keytable -p nec -t

The problem for me is with the linux constants that are not all read like KEY_PLAY and KEY_CONFIG.
For the workaround I’m going to use KEY_1, KEY_2 …

Like you I use the Keymap Editor Addon to test if they register or not.

I used to do the same, but gave up as the constant round of upgrades kept breaking things. i have just enough functionality to get by. I could never get the KEY_FAV to work whatever I did which is kind of annoying.


It’s XKB who doesn’t pass KEY_FAV by default.
If you need more details, I’ll provide.

Here is the correct link. You can rise an issue in Kodi tracker. It bugs me too.