Kody crashes on boot when using pathsubstitution for favourites.xml to a smb share (8.90.5)

I’ve migrated from latest Libreelec to CoreELEC 8.90.5 on my S905-1G-100M Box. Nearly everything works fine. My only problem is, that pathsubstitution with the favourites.xml dosn’t work for smb share. As soon as I configure it in the advancedsettigs (see below) kodi crashes during booting and then is boot into secure mode. When I have the same favourites.xml locally kodi works.

Amazing is that pathsubstitution with password.xml to the same smb share works normally. Both worked on Libreelec.


Any idea?

Have you tried turning on ‘Wait for network before starting Kodi’ ?

Yes, I have this activated (10s waiting time).

In addition to this I’ve also activated WOL for my SMB Server, so I’m shue that the fileshare is avalible.


I’s this a bug that you have seen before?
Is there something that I can do/test to give you better information?

I don’t know if “Wait for network works” correctly. DNS can be not accessible some time after.
you can try an experiment to add sleep 10 in autostart.sh and also use IP instead of host name.

I’d played a bit around with this stuff at the weekend. Last line in kodi chrash log showed:

12:57:29.459 T:4094575376  NOTICE: WakeOnAccess [DS114] trigged by accessing : smb://DS114/home/userdata/Arno/favourites.xml.

Amazing. WOL seems using my mapped favourites.xml file. So I removed the SMB part from my WOL configuration. AND … now it works.
It seems that there is somehow a conflict beetween WOL tool and Filemapping. Anyway I don’t need the SMB part in the WOL config - I still have the the MySQL part in it and MySQL is always later then SMB in my NAS.