Le Potato Segmentation Fault on Large File Transfer


#18

You can grab the schematics here: https://drive.google.com/file/d/0B1Rq7NcD_39QYnltdGtWWEFvS0U/view?usp=sharing


#19

@daxue

From that schematic, Unless I am mistaken, Ethernet is on-board of the 905X with an external PHY. So no clock feeding an external Ethernet chip.

All clocks are generated and supplied by 905X from a single external 24MHz Crystal on pins B13 & C14.

If that was unstable ALL timing including Video and DDR would be affected. Ethernet would not be singled out. The crystal is rated at 20ppm so Freq will vary between 24 000 480 Hz & 23 999 520 Hz.
Standard ppm variance.

From where I am sitting is definitely not a PLL osc.
Spec Sheet for Crystal http://41j.com/blog/wp-content/uploads/2014/08/smd3225.pdf

No doubt there are internal PLL’s in the 905X but then I would expect this timing bug to affect ALL 905X not just this Le Potato implementation.

I would have thought putting a probe on a running un-buffered OSC would skew the Freq quite a bit due to the capacitance.

I cannot find any crystals connected to a XTAL_IN. The only other one is the standard 12MHz one for the USB Hub.

The measured Freq on the above scope is 25MHz which is a HUGE HUGE variance from the specced 24MHz on the schem. That confuses me.


#20

If you look at the link I posted above to the github branch, the last two commits highlight the network issues that were discovered so far. I am not sure if your issue relates to those two. If you can replicate the issues using the mainline image, then there is another network issue that I am not aware of.
Download link: http://share.loverpi.com/board/libre-computer-project/libre-computer-board-aml-s905x-cc/image/ubuntu/


#21

Thank You @daxue

I’ll try that. Hopefully that will give a clear indication either way.

Any specific one or would either 4.14.20 or 4.14.50 do?

Regards


#22

Use the latest kernel 4.14.50. You can try it on the headless image since it is smaller image.


#23

Thank You

I’ll post back in about 8 hrs.


#24

@daxue Apologies for the delay in getting back.

TL;DR 4.14.50 does not hang on file copy operations. NFS
Corelec 8.90.3 hangs on file-operations bigger than 600~MB NFS

I have now tested CoreElec 8.90.3 & ubuntu-bionic-4.14.50-libre-computer-aml-s905x-cc-00910-g8639a27bbe1f-dirty-server-2018-06-17.zip

Both fresh installs on Samsung EVO 32GB

CoreElec 8.90.3:

Minimal Config, enable SSH. Mount NFS NAS drive. Shutdown Kodi from SSH and copy a 10GB mkv from NAS to /storage/screenshots

Copy operation & SSH session hangs after about 657MB (I used rsync so I could see progress)
Remove power and retry. Same. Cisco Switch show no network errors. FULL DupleX 100MB on that port.

Copy never completes and hangs every time. DHCP IP addr stays consistent.
MAC does not change: a626e15184ec

ubuntu-bionic-4.14.50-libre-computer-aml-s905x-cc-00910-g8639a27bbe1f-dirty-server-2018-06-17.zip:

DHCP worked from boot. New DHCP IP every-time it boots.
Config NFS and mount NAS

Copy 10GB file from NAS /var/tmp 100MB Full Duplex. No errors listed on switch.
10.9MB~ 11MB/s copy takes about 13~15 minutes.

Copy from SD card back to NAS. Same specs. No Network Errors. Used rsync.

Copy is successful every time.

MAC keeps Changing:
1st Boot: 2c7460b900020000ab11a4fc64f36f409acf
2nd Boot: 9129696800020000ab11a4fc64f36f409acf
etc


#25

The MAC address isn’t pre-programmed on the boards so MAC addresses are randomized every boot. This is a known issue with Libre Computer images.


#26

The MAC address issue can be resolved quite easily in mainline we are using CPU serial to generate a permanent MAC address, link.


#27

Were there any commits related to this transfer issue for 8.90.4? I’m assuming not since it’s not listed in the release notes.


#28

@frerk
Unfortunately I did not see any changes in behaviour when I tested 8.90.4 on Le Potato, so I don’t think so.


#31

crash_dmesg.txt (48.6 KB)

Maybe it’s been posted before but here is the dmesg output that spit out during my last lockup. I’m not sure what value it may be but thought it might possibly help.


#32

I’m still looking into the issue, I thought I had resolved it but it appears not.


#33

for shiggles i was screwing around tonight playing with the LePotato and decided to pull the dtb off the android image and load it onto the CoreElec image 8.90.5 for LePotato and initial tests my device is not crashing playing the same video about 20 seconds in.

Here is the dtb i used
gxl_p212_2g.dtb (40.8 KB)


#34

I originally believed the issue was hardware related but some users have reported that the issue does not exist in Android.

I had asked for a copy of the dtb/kernel source from the guys at loverpi so I could compare it but was informed that they are using the “stock” without them elaborating any further.

I’ve lost interest since then as I was really disappointed with the response I got.


#35

It still seems to crash only if i go in and white list resolutions. I may have to pull a serial capture of that. This is completly different then what i was experiencing before. Complete fresh install would crash. Now i change the dtb it doesnt crash until i white list.


#36

@ih8lag

I’ll test tonight. I use rsync from NFS Mounts on nas to test. Normally with kodi shutdown.
This should give me network specific results independent of kodi version etc.

Thanks for the info.

@adamg
I got similar vague answers about the LE Potato IR Wake codes from them.
They publicise the wake ability on the main page but were totally uninterested in passing along specific answers or help for their write-up except that “they won’t support it”

Quite disappointing as their write-up convinced me to buy a Le Potato.


#37

@oz-ra vague is a very apt description.

LePotato is a great device and one of my favourites and had the potential to be one of the best in my opinion but it’s creators are letting down it’s community by not communicating enough and being more open.

I suspect them not making the kernel source available is probably due to NDA reasons but the kernel is GPL licensed so it should be made available.

Khadas and Odroid have made their kernel sources available…


#38

I am quite disappointed too. I was looking to setup a 4K capable device on the cheap with kodi 18 so I would have the builtin retro player until the xbox version of kodi matured and had all the features i needed. So now I am either stuck crippled or look at another device. I can never have too many SBCs at home but the pile is starting to get big with like 4 RPis an OrangePi and a LePotato


#39

@adamg
@ih8lag

I have tried the Android dtb but unfortunately the results are not good.

See screenshot.