Le Potato Segmentation Fault on Large File Transfer

Use the latest kernel 4.14.50. You can try it on the headless image since it is smaller image.

Thank You

I’ll post back in about 8 hrs.

@daxue Apologies for the delay in getting back.

TL;DR 4.14.50 does not hang on file copy operations. NFS
Corelec 8.90.3 hangs on file-operations bigger than 600~MB NFS

I have now tested CoreElec 8.90.3 & ubuntu-bionic-4.14.50-libre-computer-aml-s905x-cc-00910-g8639a27bbe1f-dirty-server-2018-06-17.zip

Both fresh installs on Samsung EVO 32GB

CoreElec 8.90.3:

Minimal Config, enable SSH. Mount NFS NAS drive. Shutdown Kodi from SSH and copy a 10GB mkv from NAS to /storage/screenshots

Copy operation & SSH session hangs after about 657MB (I used rsync so I could see progress)
Remove power and retry. Same. Cisco Switch show no network errors. FULL DupleX 100MB on that port.

Copy never completes and hangs every time. DHCP IP addr stays consistent.
MAC does not change: a626e15184ec

ubuntu-bionic-4.14.50-libre-computer-aml-s905x-cc-00910-g8639a27bbe1f-dirty-server-2018-06-17.zip:

DHCP worked from boot. New DHCP IP every-time it boots.
Config NFS and mount NAS

Copy 10GB file from NAS /var/tmp 100MB Full Duplex. No errors listed on switch.
10.9MB~ 11MB/s copy takes about 13~15 minutes.

Copy from SD card back to NAS. Same specs. No Network Errors. Used rsync.

Copy is successful every time.

MAC keeps Changing:
1st Boot: 2c7460b900020000ab11a4fc64f36f409acf
2nd Boot: 9129696800020000ab11a4fc64f36f409acf
etc

1 Like

The MAC address isn’t pre-programmed on the boards so MAC addresses are randomized every boot. This is a known issue with Libre Computer images.

The MAC address issue can be resolved quite easily in mainline we are using CPU serial to generate a permanent MAC address, link.

1 Like

Were there any commits related to this transfer issue for 8.90.4? I’m assuming not since it’s not listed in the release notes.

@frerk
Unfortunately I did not see any changes in behaviour when I tested 8.90.4 on Le Potato, so I don’t think so.

crash_dmesg.txt (48.6 KB)

Maybe it’s been posted before but here is the dmesg output that spit out during my last lockup. I’m not sure what value it may be but thought it might possibly help.

I’m still looking into the issue, I thought I had resolved it but it appears not.

1 Like

for shiggles i was screwing around tonight playing with the LePotato and decided to pull the dtb off the android image and load it onto the CoreElec image 8.90.5 for LePotato and initial tests my device is not crashing playing the same video about 20 seconds in.

Here is the dtb i used
gxl_p212_2g.dtb (40.8 KB)

I originally believed the issue was hardware related but some users have reported that the issue does not exist in Android.

I had asked for a copy of the dtb/kernel source from the guys at loverpi so I could compare it but was informed that they are using the “stock” without them elaborating any further.

I’ve lost interest since then as I was really disappointed with the response I got.

It still seems to crash only if i go in and white list resolutions. I may have to pull a serial capture of that. This is completly different then what i was experiencing before. Complete fresh install would crash. Now i change the dtb it doesnt crash until i white list.

@ih8lag

I’ll test tonight. I use rsync from NFS Mounts on nas to test. Normally with kodi shutdown.
This should give me network specific results independent of kodi version etc.

Thanks for the info.

@anon88919003
I got similar vague answers about the LE Potato IR Wake codes from them.
They publicise the wake ability on the main page but were totally uninterested in passing along specific answers or help for their write-up except that “they won’t support it”

Quite disappointing as their write-up convinced me to buy a Le Potato.

@oz-ra vague is a very apt description.

LePotato is a great device and one of my favourites and had the potential to be one of the best in my opinion but it’s creators are letting down it’s community by not communicating enough and being more open.

I suspect them not making the kernel source available is probably due to NDA reasons but the kernel is GPL licensed so it should be made available.

Khadas and Odroid have made their kernel sources available…

I am quite disappointed too. I was looking to setup a 4K capable device on the cheap with kodi 18 so I would have the builtin retro player until the xbox version of kodi matured and had all the features i needed. So now I am either stuck crippled or look at another device. I can never have too many SBCs at home but the pile is starting to get big with like 4 RPis an OrangePi and a LePotato

@anon88919003
@ih8lag

I have tried the Android dtb but unfortunately the results are not good.

See screenshot.

So it looks like the issue I am having is not the same as yours. Maybe I should open another thread or revive my old one. But I was pretty well ignored told it was my USB HDD and got absolutely no help. I know it’s not the USB HDD as it works fine on the LE 8.2.1.2 build. I can post the serial logs of the crash on the CE dtb and the android dtb.

I wish I knew more about Linux kernel debugging I would look at the issue myself.

Hi all,

here are a few observations from my side: I’ve not only the large-file-make-Le-Potato-crash-Problem, which is totally annoying, but I also observe imperfections in USB transfers. Namely, I’ve attached a DVB-T2 dual tuner receiver, which is well supported by the CrazyCat-drivers. When I use it to watch TV, I’ve every few seconds short breakdowns in the stream, which tvheadend reports as continuity errors. However, it is nearly impossible that this comes from bad signal/reception/SNR: I am living in about 2 km distance to the sending antenna, and using the same receiver with the same antenna in the same place with a Windows PC, picture is perfect! Things get even worse: As soon as I try to use tuner #2, the image from it is nearly unusable - it stutters and breaks down every two or three seconds. Again, on a Windows PC no problem at all.

Long story short: I suspect that both, the crash and the stuttering, are not a fundamental code problems, but some timing problems. I’ve tried to understand how I can influence the hardware timings, but I cannot find much about it.

Can anyone give me a pointer in the right direction? I’d then play around with the timings and see where I get.

Btw.: All currently available mainline versions (Armbian, the Ubuntu image and the Raspbian image) work flawlessly with regard to the large file topic - I have no problems whatsoever with network and writing files. I cannot say anything to USB, since I’ve a hard time to install anything on these unfinished mainline versions.

If the loverpi-guys are unwilling to help - perhaps the Armbian team is more helpful? I found TonyMac32 very approachable when I tried to solve the problem by backporting the fixes in Armbian to Libre/Coreelec (which by the way did not solve the issue as it did in Armbian).

Cheers, Hauke

@Hauke,
Just a thought …
Have you tried reducing the antenna to a minimum to make sure the tuners are not being overloaded being so close to the transmitter?
Probably not a problem, but it might be worth the time to be sure :wink:

@JohnBoyz: Thanks for the idea! I just removed the antenna completely - SNR goes from 33 dB down to 18 dB, and effects are the same (but /me receiving a good picture even without antenna shows how close I am to the transmitter :slight_smile:). I’m rather confident that it’s nothing about signal quality. And i did not want to move the topic to DVB-T2… So my question remains: Where would I configure timings? Is it possible at all? I remember some post quite a while ago that mentioned something about RAM timings and a config file for that, but for all I search, I can’t find it…

[EDIT]Did find it: RAM timing post - however: This seems to be more complicated than I thought…

About | FAQ | Terms of Service | Privacy Policy | Legal Notice