LG OLED 65B8 No video HDR content [Solved Bad Quality HDMI Cable]

HDR definitely works for me with a new install on the U9-H.

So the test build solved your problem?

Just so I can see what is happening on your device when using the test build can you play the samsung demo file and give me the output of cat /sys/devices/virtual/amhdmitx/amhdmitx0/config from while the video is playing. thanks.

The same with the test build.
If 4096x2160@23.98 mode is selected in the whitelist (no matter either with other modes or not), my workaround with switching UI to 3840x2160@23.98 won’t work

Sorry guys, my fault… I was not able to find HDMI setting on my TV set when I was watching TV program - simply HDMI setting is not popping up in the TV menu while you are not watching anything on HDMI input :slight_smile:
Once I switched to HDMI input I saw “HDMI HDR Setting” option in the menu which was set to “Off” When I changed that to “Dynamic” HDR content is properly handled by CoreELEC-Kodi.
But I decided to use wrxtasy-kszaq LibreELEC-S912.arm- build (https://github.com/wrxtasy/LibreELEC.tv/releases/tag/

Still same problem with the test version. Black screen. Semi Official LibeELEC 9.0.0 works fine. Very Strange.

Log with no resolutions whitelisted: http://ix.io/1zSJ
Log with compatible resolutions whitelisted: http://ix.io/1zSJ

Log from LibreELEC 9.0.0 (hdr working): http://ix.io/1zSW

New test build with a different approach to work around the problem.


I just started the upload so it might take a few minutes for builds for all platforms to appear.

The build posted yesterday is not working for me same issue as before. Some stuff I tried yesterday was not HDR it seems.

We are working on it from a different angle, hopefully it’ll fix the problem.
@cdu13a will update when he has a build ready to test.

@richardc1983 Did you get a chance to try the last build I posted today?


I will have a go tomorrow, thank you.

Just an update, working fine with the latest build with whitelist disabled and colour depth switching enabled.

Not sure what you have done but it seems to have fixed it, for me anyway.

Can you explain what you have changed and why Kodi was not working that way before as you mentioned something being the new standard which you was working towards?

The change I made was in the HDMI drivers not kodi.

Before the change the HDMI driver was set to automatically use the absolute highest quality setting(YUV444) that the HDMI 2.0 standard would allow for encoding it’s video output for 10bit at uhd/4k resolutions. Some TV’s apparently don’t like this. So I changed it to use the slightly more conservative setting(YUV422), that more TV’s should be ok with.

The change from YUV444 to YUV422 doesn’t make any difference to what you will see on your TV. Since YUV422 is still better then the YUV420 used by consumer video.(Bluray, DVD, streaming formats, etc…)

As for why it was not this way before, YUV422 was at one point in time the default in CoreELEC but with all the changes and improvements with auto switching the colour space/bit depth/HDR/etc… the new code wasn’t setup that way.

1 Like

Hi cdu13a

Just replied to your other post you tagged me in, things are not working again :frowning:

Thanks in advance.

Settled down to watch some 4k as been hectic recently so not been time for any 4k action. Were on 9.0.1 and cannot play 4k again with the toggles both off. Both the toggles you mention above are off, however I am getting no signal when trying to play 4k. The GUI is set to 1080p as suggested. If I set it to 4096x 2160 or 3840 resolution 4k starts to work.

If I limit display depth using the 8 bit toggle all works ok as well but with the toggle off 4k (10bit) I am assuming is not working.

If I turn 8 bit toggle off and use the 4.2.2 toggle on then 4k will start playing but when I press stop Kodi seems to go back to no signal or is not switching back, If I press stop Kodi freezes up and I have to reboot the box to get a signal back. This is when using 1080p resolution. If I use 4096 or 3840 resolutions then it will work ok.

Can only get 4k working by setting resolution to 4096x2160 or 3840x2160 and turning on 4.2.2 colour subsampling toggle. If I set it to 1080p as suggested it doesn’t work and I get no signal.

If I use 1080p resolution I have to turn the limit display depth to 8bit and it seems to work correctly in 4k but of course it’s not 10bit.

Everything else results in no signal.

We need dispinfo output when you get no signal.
And please remind us, what brand and model is your TV?

LG B8 65" - seemed to be fine before these updates when we were last mesaaging.

log-2019-04-07-18.50.22.zip (653.2 KB)

Logs attached… This was with 4.2.2 enabled and 1080p resolution.

That’s not the dispinfo output.

Sorry I thought I had provided same logs as last time?

You need to play the video, SSH into the box and type dispinfo. It’ll spit out a URL with the log which you can post here.

Edit: Just dispinfo, no | paste needed.