Logitech Harmony with amremote

I would like to use Logitech Harmony with amremote (using remote.conf file). I’m trying to make one from scratch with some positive results.

The question I have is which profile should I choose on Harmony? For example if I select Microsoft, Windows Media Center then I don’t get any button received. But if I select Pivos XIOS DS then I got buttons received.

Before making more progress I would like to know what is the best profile to be selected? To get all buttons on remote usable.

I have a Logitech Harmony 650 remote which I configured for my X92 (S912) box. In Logitech Harmony Remote Software (7.7.0) i chose X92 as manufacturer and “OTT TV BOXX92” as the model. All buttons work as expected on X92 box. On my N2 most buttons work properly and I only additionally copied Power IR codes directly from original N2 remote to my Harmony 650, so that Power on/off works also with Harmony power button.
Which "remote.conf exactly I’m using I have no idea. Long time ago I copied remote.conf for my X92 box and when I got N2 I restored my X92 settings to it, so it’s probably still that remote.conf that is active…

Btw, I use Harmony remote ONLY to turn ON/OFF my box, for all other commands I use my wifi Rii mini i8+ keyboard…

Post your remote.conf file then :slight_smile:

Mhm, I don’t have X92/OTT TV BOXX92 :frowning:

I did use the pivos profile some time ago, but moved on, here is a link to one someone posted on the LE forum

With Pivos there are missing buttons like colored and Guide. Also moving up/down is much slower than with Flirc. Not sure where is the cause.

In Logitech Harmony Remote Software 7.7.0 => Add Device:
Device: Cable/Satellite Box -> Digital Set top Box
Manufacturer => Not Listed => input: X92 => Save
Model => paste: OTT TV BOXX92

These are all my remote files that I could find: my.x92.remote.files.zip (1.9 KB)

You can change key press settings in the Harmony.

I have a mecool KIII pro profile from the harmony database,& using it on a H96 & a Mecool Pro

But they are using the .config way of using a remote

With the Mecool KIII profile, the red button opens the tv channel list, the other colours open,the movie files, photo files, & music files.

what device are you trying to use

I tried numerous devices and they all behave the same: pressing for example key up several times moves selected item slowly. I changed delays in Harmony software without any visible change.

I managed to change protocol for amremote from NEC to RC6 with this command but final result is the same. I think I will have to stick with Flirc (but I would like to free the USB port).

fdtput -t u /flash/dtb.img /meson-remote/ protocol 5

Update: I think I managed to fix the issues. The solution was using Troubleshoot in Harmony software and change some repeat value to 0. Seems harmony can sends each button press few times by default which decoder can’t handle.

1 Like

This is my remote.conf
and keyboard.xml (26.4 KB)
It covers almost all buttons on Harmony 650. Whatever I found on the Internet some buttons didn’t work and I gave up searching :slight_smile:

It is for Microsoft/A9O-00007 and needs to use RC6 protocol with amremote changed with command
fdtput -t u /flash/dtb.img /meson-remote/ protocol 5

@vpeter: Have you recognized reaction time advantages vs. lirc with your new setup? I use a Harmony One with lirc but feel responses to key presses are kind of slow.

m4tt0, there are two settings in harmony software to make it little faster. But I didn’t compare that much because I just like Harmony even with few tiny issues :slight_smile:

@vpeter: Yes, me too, which is why I want to hold on to it. Will experiment with it. Thanks!

Succeeded fixing my problems while staying with lirc by following @anon88919003’s advice on this very forum (Logitech Harmony Setup), i.e.:

  • Setting all delays of the Microsoft Media Player device to 0
  • Adding /storage/.config/autostart.sh with:
ir-ctl -t 50000
ir-keytable -D 375 -P 100

With these change, my Harmony One is as at least as responsive as it used to be with LibreELEC on my i5 Haswell NUC.

Again, kudos and thanks to @anon88919003 for the "lirc solution" to the problem.

1 Like

@vpeter: Had some time to kill and tried your amremote configuration. It IS even snappier than the lirc solution. :slight_smile:
I only have two issues now:

  • Power toggle does not work. Did you amend anything in that regard or did it work for you out-of-the-box?
  • The fdtput command obviously has to be repeated each time CE is updated. Do you (or anybody else) know a way to make the protocol change permanent?

For the power toggle, I used the original remote power button, & “learned” it on the Harmony.

I think for power issue is because in keyboard.xml I have


and power doesn’t do anything. Removing line with noop would probably help.

Regarding fdtput I don’t know if this could be automatic somehow. As a workaround few lines in
/storage/.config/autostart.sh or /flash/post-sysroot.sh could help.

For /flash/post-sysroot.sh (untested!).

proto=$(/sysroot/usr/bin/fdtget -t u /flash/dtb.img /meson-remote/ protocol)
if [ "$proto" != "5" ]; then
  echo "Setting dtb meson-remote to protocol 5 (RC6)"
  fdtput -t u /flash/dtb.img /meson-remote/ protocol 5

Thanks, both!

@bubblegum57: I’ve done what you suggested. Had an old Harmony 650 lying around, programmed it on Hardkernel Odroid C2. The power toggle was able to switch on the N2. I then went into the Harmony configuration of my newer Harmony One, entered the MS Media Player configuration and corrected the power toggle command, by programming it using the old Harmony 650. This works to the extent, that the N2 is powered on correctly. It just still does not power off when I press the (corrected) power toggle command. Which brings me to…

@vpeter: I’ve been using the remote.conf and keyboard.xml files you have posted in this thread without amending them. The keyboard.xml file does not contain a noop line, it just assigns xbmc.Shutdown to power, as it should be, I guess. I have then monitored the kodi.log file in debug mode to see whether pressing Power Toggle on the remote produces any Keyboard: scancode event. It doesn’t. Any idea how I can take it from here?

And thanks for your script. I’ve put it in the flash folder and will see how it goes, next time I update.

OK, I’ve figured it out: Firstly, @vpeter, you were right. There was a noop entry in the original file. I placed it in userdata, forgot it and later placed another copy under .config/rc_keymaps. Apparently, the one in userdata took precedent, so my changes in .config/rc_keymaps were overruled. I’ve then just kept the file in userdata, removed the noop line and now the N2 powers off when I press Power Toggle using the original Microsoft Media Player Power Toggle command.

However, I then realized that the same Power Toggle command does not work for powering on the N2. I assume that the reason is the switch in remote protocol that we applied. My “solution” was to simply program an additional command N2PowerOn on my Harmony for the Microsoft Media Playerdevice using the Hardkernel PowerToggle command. I then added that command to the Watch Kodi action start sequence in the MyHarmony software.

I don’t know whether there are easier ways to fix this, e.g. by adapting the config.ini, but I haven’t been able to do it using the standard guides that float around the internet…