MPD server addon - no sound


First of all best wishes for this new project!
Since I use Odroid-C2, I’m glad that development community for this board is now stronger than ever :wink:
I’ve tried latest release and I’m impressed with video quality and overall stability in this “alpha” stage.

Everything works, except audio for MPD server…
I’ve tried all posible ALSA combinations in mpd.conf without success:

  • #device “hw:0,0”
  • device “hw:0”
  • device “hw:0,0”
  • device “hw:0,2”
  • device “default”
  • device “default:CARD=AMLM8AUDIO”

aplay on all of this devices (except “hw:0,2”) with WAV file plays just fine on HDMI and on analog and spdif-out from HIFI Shield 2, so I’ve suspected on mpd build in addons, and compiled latest mpd from source on ubuntu 16.04 minimal on the odroid itself.
in ubuntu and even archlinux, newly compiled mpd works ok so i’ve copied all bins and libs from ubuntu back to corelelc and found same problem like official mpd addon :frowning: I’ve even removed HIFI Shield 2 to test only on HDMI with same result.

this is the log from mpd:
May 09 23:02 : playlist: play 5:“Destroyer/2015 - Poison Season/06 - Girl In A Sling.flac”
May 09 23:02 : decoder_thread: probing plugin flac
May 09 23:02 : decoder: audio_format=44100:16:2, seekable=true
May 09 23:02 : alsa_output: opened default type=HW
May 09 23:02 : alsa_output: buffer: size=16…65536 time=362…1486078
May 09 23:02 : alsa_output: period: size=8…8192 time=181…185760
May 09 23:02 : exception: Failed to open “Analog” [alsa]
May 09 23:02 : exception: nested: Error opening ALSA device “default”
May 09 23:02 : exception: snd_pcm_hw_params_set_buffer_time_near() failed: Invalid argument