MX Pro+ 4k won't boot

See here for different methods to try :wink:


I tried the reboot into recovery option and that just reboots into the anroid recovery menu.

Is that the correct dtb for that box?


99% percent I’ve tried all dtbs now, both with the tooth pick method and rebooting into recovery.


Any one have any ideas?


Did you try all USB ports? Sometimes only one can be used to boot CE.

Yeah tried all ports and the sdcard slot.



I’ve come to the conclusion that this box just won’t work with CoreELEC. Even tried a older Libreelec build.

Nope nothin. Avoid this box.


According to product description, it’s S905W.
did you try the p281 dtb?

I didn’t see that.

I opened it and it says s905x on the board.

But I’ll try when I get home.



Did you manage to solve this? I’m looking to purchase the same box and am worried it won’t work. I saw a review on the USA Amazon site where a guy stated he used the gxl_p212_2g_nand.dtb file and it worked.

Was it really a S905X or was it fake since the description on the UK Amazon website states S905W.



I did solve it yeah, not a bad box.

I can’t remember what dtb file I used, I’ll look when I get home.

But it’s definitely a s905x.


Hi Matt,

Thanks buddy, I’d really appreciate the help. I just placed my order so fingers crossed it works! I just want a basic box that runs Kodi well. Will save me from lugging the laptop downstairs every night from the office.

Kind regards


There’s a reboot to libreelec.apk . I had to download the reboot to libreelec.apk to a usb to install on to andriod. I have a different box but had the same issue. Just add that apk and when you click on it, it will boot from coreelec until you tell it not too or until you remove the sd card.

Similar problem here with an MXQ Pro 4K.
I tried both the toothpick method and reboot to libreelec.apk, both from USB and SD.
I believe I used the correct DTB (gxl_p212_1g according to this list).

Any ideas?

Use gxl_p212_2g_slowemmc.dtb Dtb file, boot into android and run ‘reboot update’

Should work then.


Thanks Matt.

Just tried this dtb, and once again, it booted directly into the stock Android, instead of CE.

(To be fair, I used the ‘reboot to libreelect’ app because I didn’t have a terminal emulator installed, but I believe all it does is simply run reboot update)

EDIT: Also tried gxl_p212_1g_slowemmc.dtb - same result

Have you tried all the USB ports?

Mine boots from the one nearest the back.


With the regular dtb I tried all USB ports + SD

This box needs the slowemmec dtb.

Did you try all usb ports with that dtb file? It won’t boot with any other dtb.


There are some version of media player with the same name.

In my case I am using MXQ pro 4K, 2GB RAM with S905W.

gxl_p281_2g.dtb boots OK from SD card and USB stick. You must use the USB port near to the SD card reader.

Wifi and Ethernet are working without problems.

I am trying to put the original remote controller to work.

If your CPU is S905X you sould use another dtb.

3 posts were split to a new topic: MXQ Pro No WiFi