My PVR Addon doesn't work on 8.95.5

Looks as though the 8.95.5 update breaks the NextPVR addin - fails to start with “This add-in not compatible with this version of Kodi”.

Uninstalled the NextPVR addin (

Upon downgrade back to, trying to reinstall the NextPVR addin fails because “The dependency on kodi.binary.instance.pvr version 5.10.4” could not be satisfied."

Same issue on downgrade to 8.95.3 (which I know had been working previously).

Any ideas? Thanks!

TVHeadend HTSP Client is incompatible with this install … or so the message tells me after a reboot.

Something about a dependency on
kodi.binary.instance.pvr version 5.10.3 … (the rest is lost)
scrolls at the top of the screen, after I uninstalled it and attempted to reinstall it. It does not install.

1 Like

Hi after update pvr.iptv.simple.Client no working.I try install from zip but no you have some issues for this problem thx

i had a similar prob with the VDR plugin, after updating the plugin was automatically disabled and kodi did not detect a PVR client …

while i solved that bit by manually deleting and re-installing the plugin, there is a serious bug with this PVR Client popup message.

obviously it blocks kodi and comes up before the CEC support is loaded so you can not dismiss the message at all unless you get a keyboard and hit enter (right after dismissing the message, the “loading CEC…” popup appears and the TV remote becomes responsive)

In case someone missed it, please see post #1 for instructions on how to fix the PVR addons.

Ok, thanks. Problem solved

didn’t work for me

What didn’t work exactly? Post a log.

With the new version, TVheadend HTSP client had to be disabled due to incompatibility (reported by coreelec itself). I then followed the instructions in the first post, uninstalled the TVheadend HTSP client, deleted the addon zip, but when I tried to install the addon from the repository, I had an error message similar to some of the messages here - something about dependency on kodi.binary.instance.pvr.

I enabled logging on the system and below is a section of the relevant code when I tried to install the addon
18:38:53.625 T:4092784560 DEBUG: CAddonInstaller: installing ‘pvr.hts’ version ‘’ from repository ‘repository.coreelec’
18:38:53.633 T:3719295856 DEBUG: CAddonInstallJob[pvr.hts]: requires kodi.binary.instance.pvr version 5.10.3 which is not available
18:38:53.634 T:3719295856 ERROR: CAddonInstallJob[pvr.hts]: The dependency on kodi.binary.instance.pvr version 5.10.3 could not be satisfied.
18:38:53.642 T:4092784560 DEBUG: CGUIMediaWindow::GetDirectory (events://)
18:38:53.643 T:4092784560 DEBUG: ParentPath = []
18:38:53.643 T:3731608432 DEBUG: Thread waiting start, auto delete: false
18:38:53.644 T:3731608432 DEBUG: Thread waiting 3731608432 terminating

On another matter, which may be related, the addon inputstream adaptive could not be updated as well (I don’t know what this addon relates to). When I looked at the log, this was the section I found
18:33:46.389 T:3976188784 ERROR: CCurlFile::Open failed with code 404 for
18:33:46.390 T:3976188784 ERROR: CAddonInstallJob[inputstream.adaptive]: failed to download special://home/addons/packages/

Any ideas on this as well?

Did you delete the zip file from /storage/.kodi/addons/packages?
All the addons were rebuilt, Kodi keeps trying to install the old version. That or you’re using an old build, you must be using 8.95.5.

I followed the instructions in step 1 to the letter including deleting the zip files from the packages directory.

I checked after the upgrade to ensure that I was on 8.95.5.

Maybe I will manually download the 8.95.5 again and manually upgrade

Which version of the add-on are you trying to install? Do you have 1 or 2 options?
From what I can see, the version currently in our repo is, not doesn’t even exist in our repo, so I don’t know what’s going on there, but Kodi keeps trying to install a version that is somewhere on your box.
SSH into it and do a search for pvr.hts: find / -name pvr.hts Look for a zip file with in its name, and delete it. rm "full-file-path"
Then reboot and try again. continues to show as an option for install here.

Go to the left pane while displaying Addons/PVR Clients (with TVHeadend HTSP Client highlighted) and clicking on “check for updates”

Those were the instructions from TheCoolest which now seem to have disappeared.

I’m looking at the repo right now and it’s showing for me.

1 Like

This is really weird and frustrating. I can see The Coolest screenshot with the new version of Tvheadend HSTP client. But for the life of me, it is not available for my box. Here are the things I have tried so far

  • manually updated coreelec to version 8.95.5 again. Confirmed that the box is running the correct version
  • deleted all instances of files with pvr.hts. In fact, I have used WInscp to get to the box and searched from root unsuccessfully for any file with pvr.hts - with no result. So the incorrect version is not on the system
  • downloaded the zipped file of the coreelec repository (dated 3rd October) and updated that in my addons repository

Despite all that, the version showing up when I tried to install Tvheadend client is still I have also unzipped the repository file and looked at the file structure and seen a download for, which I have subsequently downloaded and viewed on a notepad. I can see the new version of Tvheadend client listed as, but there is also a version listed.

It is so close and yet so far. What else should I try, before someone tells me to do a complete reset to default or a complete clean reinstall?

Is there any way to manually install the version? A zipped file to download manually perhaps?

There’s another method, that seems to have worked for me previously.
Only use it as a last resort, AND set your GUI language to English before attempting it
It’ll disable all installed addons (won’t remove them, but will disable them), but it should let Kodi properly refresh the repo:
Delete /storage/.kodi/userdata/Database/Addons27.db and restart Kodi.
If all else fails, you can install from a zip, but it may fail to automatically update in future CoreELEC releases. (324.9 KB)

You the man!

Deleting the addon database did the job! Just in case, I copied the Addons27.db somewhere else before I deleted it. After reboot, the correct version of the Tvheadend HTSP client showed up, and when selected, there were two versions offered. Choosing the correct version allowed installation.

In addition, I also managed to install the inputstream adaptive addon - again, I don’t know what it is linked to but I uninstalled it previously when it failed to update.

Thanks again for your knowledgeable help and the zipped file. I am sure others will find this discussion useful and it seems a bit weird that the addons database cannot be automatically updated

Hello all,
I think there are some weird relation between tvheadend hts client add-on and interface language.
I have playing around 2 months with x96 mini and coreelec. From the beginning after clean boot when installed tvheadend hts client add-on and immediately change interface language i have system crash and reboot to safe mode. If no change to interface language - everything is ok.
Today i’ve rebooted to apply pending update to 8.95.5 and the story go’s again.
Thank you for your attention.

Hello @TheCoolest, I saw that you have two PVR IPTV Simple Client installed. Is it possible to install more than one and use different m3u list?

Thanks for your answer!

One is IPTV Simple, and the other one is IPTV Archive, it’s an extension of the IPTV Simple to add support for archive. You should be able to use both for 2 different playlists.