MYSQL library erased on 'clean library' command

Hi all.
Firstly, if this has been posted in the wrong forum section, or if it’s not a CorElec issue, can a Mod please move (or delete) it.

In a nutshell:
I have 3 devices running Kodi, using a shared central MYSQL library database (Odroid N2+, Windows laptop & Windows desktop).

Before I had the N2, I had an Intel NUC running LibreElec & the shared MYSQL database worked flawlessly. Since changing the NUC to the N2+, any time I manually clean the library, the video database is essentially erased (for lack of a better term). The source folders are still mapped in Media Sources but the content gets reset to defaults & any watched status is lost. I have to then rescan all the media to the library again. This then affects the other Kodi clients, resetting them as well.

On startup, the library is set to scan for new content & clean as usual. Dead links for deleted media do not automatically clear like they once did. If I select the dead link, Kodi asks me if I want to remove the nonexistent file (which is fine) but if I manually clean the library the database resets as described above.

Any idea what’s happened since replacing the NUC with the N2+ & is there something I need to change in CoreElec or MYSQL to fix this annoying problem?


Not sure if I can help. I have only just installed mysql onto my synology nas.

From the instructions, I found, I enabled mysql on my Nvidia shield (MrMC)

I then added a modified advanced settings file to the android version of Kodi, & added the same modified file to my X96 Max+
IF you have done similar, have you placed the advanced settings file to the correct location in the N2+ ??

Thanks for replying bubblegum57.

Sorry, I should have specified that MYSQL is set up on my Synology also & that I have one advancedsettings.xml that has been copied to each Kodi client’s userdata folder.
I also neglected to mention that I have a 4th Kodi client set up the same way (Kodi on my Sony TV).

When I originally set up MYSQL, the original modified advancedsettings.xml was created for the NUC (my most used Kodi device) & then copied to the other client’s userdata folders. When I set up the N2+/CoreElec, I copied the advancedsettings.xml from the desktop client.
Is there a chance something has been lost by deleting the ‘master’ advancedsettings.xml that was on the NUC? I assumed they were all identical.

All I can think of, is either the location is different. Or you need to set the port to 3307. The original guide I tried said use 3306. Other thing, the guide is saw used a password of kodi, but when I set it up, there was a minimum number of character required. This was on the syno php. Oh, another thing, a couple of times I had to delete the database on the syn.



OK. Thanks for that.
Looks like I’ll have to play around a bit when I’ve got some time.
I think you’re on the right track & I appreciate your help.

Do you actually use MySQL or MariaDB? And which version exactly?

MariaDB v 10

You might have that compression problem I described here somewhere. Try to switch compression to off whereever possible.

Thanks all for the suggestions & help.
I found that 1 of my 4 Kodi clients was using SMB shares, while the other 3 were using NFS. All 4 are now on NFS & share the same advancedsettings.xml & sources.xml.
In addition to this, I deleted my MariaDB database & started from scratch again. This has fixed the problem & all 4 clients are in sync & removed file links no longer remain in the database.
PITA but all good now :slightly_smiling_face:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.