N2 HDR washed out

Hey there,
first of all I want to give the devs a big THANK YOU!
Got my N2 a few days ago and I’m really impressed that everything works so well! I got an Philips 65" 4k TV and Denon x2300. Atmos Passthrough works out of the box, GUI performance is very good. (I am coming from an i5, gtx1060 box and never expectet that the look and feel could be almost as snappy as it was on that PC.

Now to my issue, well, I dont even know if it is an issue, but HDR seems to look washed out, so maybe there is something not properly set up by me. I have to admit, that I got only two files to test HDR, but on those colors seem a little washed out, comparing in-video-black to the black bars on the top ant bottom, it seems greyish.
I remember that vanilla Kodi hat a setting to switch between limited and full range output, but I cant find that in CE…!?
When I play a HDR video, the TV switches into HDR Mode, so thats very good. (it never worked on Win without MadVR and that is one of the reasons I wanted a dedicated KODI box)
Please let me know it there is some obvious setting that I might have missed or if you need any logs to help me with my problem.

Thank you guys

There is specific ports on PHILIP’S TVs for HDR and you also have to enable HDR in the TV HDMI settings.

Thank you for your reply!
As I mentioned, i had it working with madvr on that same input (HDMI 1)
Afaik, HDMI 1 and 2 are the 2.0 compatible inputs
Also, there ist a setting on the TV, which lets me choose chroma aubsampling for those two inputs. I have them set on 4.4.4, as I understand that should be the default for most 4k HDR videos on CE, right?

I attached a sceenshot from the TVs Settings menu:

I forgot to mention, the AVR ist set to passthrough the video signal directly, so i suppose its not the AVRs fault.

I’m confused. You said washed out colours but also said tv switches to HDR mode.
You got washed out colours when your tv in HDR mode?
You can rule out your AVR if you connect your N2 directly to the tv.

As i said, right now I got only got two files to test with. I will download some proper test files and try with those, maybe it was just a bad video file.

Note that VP9.2 codec HDR files will not trigger HDR in the display, it seems to be a limitation we have with the Amlogic drivers. Make sure you use HEVC demos to check HDR. There are plenty of good samples on https://4kmedia.org/