N2+, Vizio TV, "Resolution Not Supported"

The ones I tried today were streaming files from an addon.

After messing around with it some more, it seems there is some type of hdmi video syncing issue which may be related. If I turn the tv off and let the box running and turn the tv back on later on, sometimes I get the Kodi screen and sometimes I get a complete black screen and sometimes I get “resolution not supported”. If I turn the tv on and off a few times, the Kodi screen usually “comes back”. This issue also happens on multiple addons sometimes when I hit the “X” key to terminate watching a streaming video.

With my Raspberry Pi 4 and LibreElec I never had this particular issue.

Sounds like its down to the HDMI handshake, I wrote a troubleshooting guide for just this kind of issue.

This thread was edited so you can proceed seeking help @dootsie .

1 Like

As far as I can tell, the Vizio TV is up to date software-wise. It’s been connected to the internet. I didn’t see any way to force an update.
I tried another HDMI cable. That didn’t seem to help either.
Which file from “device_trees” should you use on the N2+, g12b_s922x_odroid_n2.dtb or g12b_s922x_odroid_n2plus.dtb?
I tried both and neither seemed to have any effect on the problem but I just want to be sure.

Maybe I should document what I did for the install in case I made any mistakes.

I downloaded “CoreELEC-Amlogic-ng.arm-9.2.7-Odroid_N2.img.gz”, extracted it and wrote the image to an sd card. I copied the g12b_s922x_odroid_n2plus.dtb file to the root and renamed it to dtb.img. I put the card into the N2+ and booted it. Then I copied my LibreElec’s samba.conf file to the card’s .Config dir and rebooted again.
I then copied from my LibreElec backup the “.Kodi” directory to the “.Kodi” directory on the N2+ box. I just pasted the backup .Kodi dir over top of the existing N2+ .Kodi dir. I didn’t delete any existing files from the N2+ .Kodi directory before doing the paste.

I also transferred the sd card to a 2nd N2+ box I had here just to make sure it wasn’t an N2+ hardware defect issue. I experienced the same problem on that box as well.

I took my N2+ box to my friend’s place last night so we used his HDMI cable and TV. The problem didn’t happen there, however, we didn’t watch many different videos either. Sometimes here at home I have to watch quite a few different videos until the problem happens. Other times it’s only a few files.

Finally, the problem never happens when the video is playing. It only happens either when you try to play the video or when you end watching the video either by hitting “X” or by fast forwarding/skipping to the end. This is all with streaming videos from different sources (minimum of 3 sources)

At this point, I’m stumped and annoyed.

Any further advice would be greatly appreciated.

That’s pretty much it.

As far as I can see you have so much unconventional steps that it’s hard to start, but let’s try it. First, there’s no need to extract anything. You just burn the downloaded image with rufus or etcher. Then, as this is a N2, you don’t need to copy dtb because, by default, the N2 has a dedicated image with the correct dtb. Then things start to get ugly, the samba copy from Libreelec part is maybe acceptable but not what I would do. I would just redo the configuration. In the end, the part where you copy .kodi around between Libreelec and CoreELEC is the icing on the cake. I wouldn’t do it even if I was payed to do it.
In the end, you should just install cleanly and try everything fresh and rebuild your config from there.

PS-Probably that’s not the root of your problem and you must check hdmi, maybe use a disp_cap file with all the resolutions supported, etc.

Maybe this workaround will help. You have to specify a resolution and frame rate your TV supports. The important part is that kodi can change it once on startup.

Ok, I was just following the install instructions on the www.coreelec.org → Install Guide.
I write the .img file to the card using Win32diskimager…
I can try just writing the .img image to the card and not copying over and renaming any files from “device_trees” and continue from there to see if anything changes. I’m thinking it won’t make any difference but I’m willing to try mostly anything at this point.
I’ll do that and then check the samba.conf N2 against the LibreElec one. I don’t see why that should make any difference / affect the playing of videos though.
The .Kodi directory is just python files for all the addons. Why would those be any different from LibreElec to CoreElec? I’m not an expert in Kodi, but I don’t see why there would be any difference that would affect the playing of videos.
How do I do what you were referring to with the “disp_cap” file?
That might be the best place to start before I do anything else. It just seems like the TV and the N2 aren’t in sync or fall out to sync. The fact that I get “Resolution Not Supported” makes me VERY suspect of some type of display/resolution (hardware handshake) type issue more than a Kodi python code issue.

You say that you have some problems in CoreELEC, I’m just telling you that the best way to track down problems is not to introduce more variables to the problem. You do as you please, everyone is free. Regarding disp_cap, you can do a search in the forum to see how that goes.
If you think that the problem is really in CoreELEC, please provide a small sample of a file you’re having problems with. If you only have problems with some streaming addons, please go to kodi forum and direct your problem to the addon creator. If you have problems only with piracy addons, you’re really on the wrong place to solve them.

What is the model of your TV? Vizio has many different models.
Also, enable the force 4:2:2 option in CoreELEC System settings, and see if that solves it.

dootsie. Do what @Vasco said, revert back to a clean install on the N2+, copy the samba config and don’t copy the LibreElec Kodi files as your just asking for trouble because its virtually certain there will be a path mismatch somewhere in there.

Having read a few of the online reviews and the problems people are having with the Vizio TV’s and the game consoles. I’m pretty sure that its nothing to do with either the N2+ or Kodi or CoreELEC and all down to the Vizio TV as the same issue is getting reported when people use gaming consoles and no they haven’t found a fix either, unless you count returning it under warranty for a refund as a fix.

You have to remember that Vizio TV’s are built to a price and subsidised by selling on personal data, your best off trying it on a different TV once you do a reset and if the problem goes away then its a hardware issue with the TV.


Vizio E40-C2.

I found that (4:2:2) setting in System → System → CoreELEC. (I’m documenting it in case someone else is looking for it)
Well that didn’t take long. The first video I played and hit “X” to end gave me the “Resolution Not Supported” error again.

So far I’ve tried the 4:2:2 setting, verified I have the correct dtb.img file for the N2+, verified no change to the Samba.conf file, made sure the TV has the latest update and tried 3 different HDMI cables.

I’m probably at the point now where I’ll have to bite the bullet and do a fresh install. (I still don’t think that that is the issue.) I’m not looking forward to that as the full install will probably take 4-5 hours. I recently did that on my Raspberry Pi 4.

Why do you think that I’ve never had an issue like this running a Raspberry Pi 2, 3, and 4 on that same TV with OpenElec and LibreElec on those boxes? I’ve also had/have satellite receivers, vcrs, and dvd players connected to that same TV with no issues. I’m not saying that it may not be the tv, but I would have thought if that was the case that I would have run into problems with other equipment prior to this.

LibreELEC for RPi4B doesn’t have adjust display refresh rate turned on, where as CoreELEC on Amlogic devices does have it turned on. So perhaps your video is running at a resolution & framerate that causes CoreELEC to switch and your TV doesn’t support it. On CoreELEC, I have to go through each resolution, refresh rate, and do video calibration if the TV has overscan, and then whitelist resolution/refresh rates that are supported.

Doing a clean and lean install takes 5 minutes. You can copy over the relevant kodi files with sources/passwords from your existing installation. You just need a separate USB/SD card to do it.

CoreElec has different settings from mentioned OSes that can cause your problem. I think that only a fresh install will get you on the right path.

Are you referring to the “addons” and “userdata” directories?

When they refer to a “clean” install, I automatically think they are referring to a fresh OS install AND installing all the addons from scratch and setting each of them up individually. Maybe I am misconstruing what they are saying.

I’ve never had to go through that Whitelisting process before. What exactly is involved and how do you do it?

It is explained a bit here:

But what might be useful is the OSMC guide on the subject, it may have some device specific settings but there should be a lot of similarity with CoreELEC.

As I understand it, and experts can correct me here, it is used to resolve issues where your EDID reports resolutions & refresh rates that are not actually supported by the TV (which is weird if you ask me). Because I think Kodi would start there, and it will adjust the display resolution & refresh rate on video start/stop automatically to match what is closest to the video.

You don’t need all addons to test whether the clean install fixes your issue or not.
You only need to test your videos.

Is there any way to disable adjust display refresh rate on CoreELEC to test whether that is the issue?

No, and that setting is completely irrelevant in your case; when it was used it worked only when video player was in use, and had no effect on GUI.