Netflix and Odroid N2 dark scenes

Hello. I have Odroid N2 with the Netflix addon, in dark scenes, the images are pixelated and the images look very bad. I’ve tried the Netflix application on TV and it looks perfect there …

What resolution do you use for Netflix streams on N2 ?

I think what you mean are compression artefacts. That’s a common issue with Netflix on Kodi because your device has to decode the video in software whereas your TV can decode the video in hardware since your TV is Netflix certified and your N2 isn’t. Unfortunately you can’t do much against that. You can go to the Netflix settings and select input stream adaptive settings and in there set the min Bitrate to the highest possible value but that will just help a little bit

@Sholander The resolution in Coreelec is 1920x1080, the rest of the options on the white list are disabled.

@nct I’m sorry to read that. The truth is that I imagined that something like that could be the cause … it’s a shame, I love Coreelec as my multimedia center and I enjoy Netflix with ambilight and hyperion.ng.
In addition to the recommendation you have given me for imputstream, is there anything in the Netflix addon configuration that can improve image quality a bit?

I’m afraid I don’t know any except making sure your device has a stable and fast internet connection and a good enough power supply to deliver it’s full performance. It’s a real bummer that big streaming services make it so difficult to use open and uncertified devices.

If by any chance you have selected “Enable VP9” in Netflix -> Settings -> Expert, disable that option.

This option is disabled, I already verified that it distorts the image and fails a lot. Thank you all.

Is this dark scenes pixelation present on all NF videos, or only on some. I remember having it on some episodes of Jessica Jones S2, but not on all. Those episodes looked OK with my LG TV NF app.
Btw, to which TV is your N2 connected. Maybe trying with some “smart” settings on your TV to reduce pixelation will get better picture. Usually TVs have default sharpness setting wrong,

The truth is that I have to try more series and movies to be able to affirm whether it is in some specific cases or in all. Where I have observed it most is in series like Dark and (the one I am watching now), Marianne. My tv is a Samsung Smart TV where I have disabled all the smart functions and, in the Netflix application of TizenOS I don’t have the problem that I mention here.

Hmm, Sharpness setting is not a part of “smart” settings so try with that also.

Btw, there is a CE option that I run in “autostart.sh”, don’t know if it’s still needed, to disable noise reduction:
echo 0 > /sys/module/di/parameters/nr2_en
Try that if it makes any difference…

It should also be noted that many TVs have a hardware “de-noise” or similar function that can clean up some artifacting caused by compression. It’s possible this is in-use by default on the built-in NF app, and not on a standard input.

On some videos in Netflix I get some artifacting on dark backgrounds. It looks kind of blotchy sometimes is the best way I can describe it, a little like over-compression but not exactly. I haven’t mentioned it before, but now that someone else is complaining about it I just want to say I’m seeing it to. I wouldn’t say it’s unwatchable, but it’s an obvious flaw in the video rendering.

I’ll check that VP9 setting, but otherwise my setup is pretty simple, running an N2 into AVR with an older 1080p TV (Samsung Smart TV, possibly similar model to the OP’s). I have none of the TV’s built-in denoise or other filtering functions enabled either.