New CoreElec N2 final came...need some guidance..plz

Greetings. After placing and order for my N2 on Sept. 3 it finally came yesterday. Anyway I ordered the 4g memory with the default 8 g scandisc card loaded with the nightly build of CoreElec. Started up and it downloaded the newest nightly and rebooted. All fine so far. Hooked up HDMI to AVR which in turns supplies my projector or TV. Everything running ok for my 1080 content, so I try Blue Planet II 4K and it plays ok. Switch to Baby Driver in 4k and sounds comes on but a black screen. Reboot and try again, this time it works, but now the Blue Planet will not display.
Went into settings and turned on force to 8 bit. This worked but will not work all the time, meaning some 4k play others will not.
Coming from my Minix uh-9 where everything switched fine I am wondering what I need to do to re-create the switching ? Also my plan was to use the Minix A3 remote, but it seems that it will turn off the unit but will not turn on. Most of the other keys do work.

My initial thoughts on the N2 are that it runs very snappy and loads quickly, but with the exceptions listed I am not ready to turn it over to my media for full time duty. Will stay with my Minix for now.
Thanks for reading.

You need to edit your config.ini to get power on from the remote.
You can find ‘how to’ in this forum.
N2 is my daily driver from the beginning and never experienced your issues with any 4k content.
When you have black screen then ssh to your box and run dispinfo and copy the link you got and post here.

1 Like

Thank you for your response.
I have a log file if that would do for now otherwise will have to wait until I get off work to get the other info you want.

I can not get the N2 to start from the remote. I downloaded all the codes from the other posts and used the Harmony Elite (MINIX U-9H) code. I did need to ediit the file that is placed in the storage/config as it was missing the # table minix_neo, type: NEC in the first lline. Did not work.
I then went and did a scan for the key code to see if it matched the config. it does. Next went and SSH’d to get the remotewakeup key. After getting that I nano’d the config ini and saved and rebooted Nothing I have done will turn the N2 on.

You put “minix_neo” for the device? I thought this was refering to the N2, not that this would fix it but I have been unsure what to put there as the examples I have seen put the device name there.

Does your TV have HDMI CEC, I know it can be a pain but for just turning on the N2 it has worked well for me.

Yes I put the minix_neo as device as I changed the name of the file in the storage/config/rc_keymaps to minix_neo instead of elite. So I needed to change the rc_maps.cfg to reflect that change.

And as far as CEC HDMI, I haven’t played around with it. I run the N2 to my Nad and then to either a TV or to my 4k projector.

I normally just hit the power button on my remote for the Minix and then power on the avr , then either turn on TV or projector depending on the time of day.

This is my scan codes from ir-keytable -r
CoreELEC:~ # ir-keytable -r
scancode 0x0104 = KEY_MENU (0x8b)
scancode 0x010d = KEY_HOME (0x66)
scancode 0x0110 = KEY_VOLUMEDOWN (0x72)
scancode 0x0112 = KEY_CONFIG (0xab)
scancode 0x0114 = KEY_VOLUMEUP (0x73)
scancode 0x0115 = KEY_RIGHT (0x6a)
scancode 0x0116 = KEY_DOWN (0x6c)
scancode 0x0118 = KEY_POWER (0x74)
scancode 0x0140 = KEY_BACK (0x9e)
scancode 0x0146 = KEY_UP (0x67)
scancode 0x0147 = KEY_LEFT (0x69)
scancode 0x0155 = KEY_ENTER (0x1c)
Enabled protocols: lirc nec

This is my contents from storage/Configfiles/rc_keymaps/minix_neo file:
# table minix_neo, type: NEC
0x139 KEY_0
0x130 KEY_1
0x131 KEY_2
0x132 KEY_3
0x133 KEY_4
0x134 KEY_5
0x135 KEY_6
0x136 KEY_7
0x137 KEY_8
0x138 KEY_9
0x146 KEY_UP
0x116 KEY_DOWN
0x147 KEY_LEFT
0x122 KEY_FIND
0x10d KEY_HOME
0x126 KEY_PLAY
0x140 KEY_BACK
0x104 KEY_MENU

And my rc_maps.cfg
# Keymaps table
# This table creates an association between a keycode file and a kernel
# driver. It can be used to automatically override a keycode definition.
# Format:
# driver - name of the driver provided via uevent - use * for any driver
# table - RC keymap table, provided via uevent - use * for any table
# file - file name. If directory is not specified, it is first looked up
# in /storage/.config/rc_keymaps, then /usr/lib/udev/rc_keymaps
# For example:
# driver table file
# gpio-rc-recv rc-streamzap streamzap
# gpio-rc-recv * justboom
# * rc-rc6-mce rc6_mce_new
# * * hauppauge_new
meson-ir * minix_neo

Finally the wake up codes
Received IRMP code: remotewakeup=‘0xe718fe01’, decode_type=‘0x0’, remotewakeupmask=‘0xffffffff’
Received IRMP code: remotewakeup=‘0xe718fe01’, decode_type=‘0x0’, remotewakeupmask=‘0xffffffff’