NEW Repo for Remote files (Thanks to Betatester)

Original Repo

How to configure IR remote control
Remote configuration hell
X96 mini does not boot
[Solved] Mecool M8S Pro+ not working
Dual booting - how to switch?
How to configure IR remote control
X96 Max - LCD & Remote
Remote control mini mxiii
Remote not working on S912 Beelink GT1
X96 Max Plus remote STOP command
Coreelec on Tanix TX3 S905X3
New here, and questions about the MXq box
:question: Which DTB do I use?
Remote stopped working after upgrading to CoreELEC 9.x
Amlogic S905X3, S905Y3, S905D3 thread
{SOLVED} H96 pro + not booting from USB
Remote control X96 mini
[S922X] X88 King
How to manipulate remote files?
CoreElec freezes on welcome screen
Corelec or leaving android
[SOLVED] Magicsee C400 plus - remote setup help
Mecool m8s plus dvb
IR controller doesn't work after configuration
[REGRESSION] Long Press menu doesn't work
8.90.5 - Mini M8S II - remote controller doesn't work
Remote not working - Yundoo Y2 (S912) 2GB/16GB
Gt King Coreelec samsung smart remote
Remote communication server failed to start? - Solved
Question about new MECOOL KM8 Google Certified Box
CSA93 Amligic S912 remote.conf
Updating M8S PRO+ S905X or not - beginner questions
What remote is enabled by default in rc_maps.cfg
WeTeK remote give freeze
Sunvell T95X: Stuck at Setup Wizard
Upgrade to 8.99.1 S912 H96 Pro+ cannot turn on with remote
Cannot complete installation on new box (S905X3)
Coreelec does not boot in X96 mini
Can't Run Any TVHeadend Add On
Sunveil T95Z+ remote control settings
Nexbox A95X (1gb) power-on from IR remote?
A95X -R1 / S905W issue
A95X -R1 / S905W issue
MeCool KM8 P TV Box Amlogic S912 1GB fails to boot with CE 8.90.2
Help with the remote.conf

Pinned this topic, thanks for spending the time to collect these.


Thank you.Do all of WP2’s keys work?

I don’t know, I don’t have that device. Click on the link for the LE forum, you can look at the comments there.
Or, after backing up anything you have, try the files

Yes,Some keys of WP2 do not work.

When assigning to non-working keys, they all do the same task.

Well, if you do create a working one, perhaps you could help the community by uploading here so I can put it in the above repo

X92 remote example
There are 2 modes available for remote: remote or keyboard

X92 in remote mode (1.9 KB)

Green buttons description

6 - works as backspace
5 - work as guide button
4 - in PVR - OSD Channel list, in main menu as TV channel list
3 - works as home button
2 - change audio stream for video content
1 - info about video or about PVR channel, in main menu it open settings

  • copy the file “X92_remote” to /storage/.config/rc_keymaps/ and “rc_maps.cfg” to /storage/.config/
  • copy “remote.xml” to /storage/.kodi/userdata/keymaps/
  • reboot

X92 in keyboard mode (with longpress buttons) (2.1 KB)

Green buttons description


  • works as backspace on virtual keyboard
  • delete for selections and return in all other places
  • at home screen - go to weather


  • main screen - channel EPG
  • PVR - channel EPG, longpress as EPG
  • video - bookmarks


  • in PVR - OSD Channel list
  • in main menu as TV channel list
  • as context menu somewhere, longpress as other menu


  • shows player info for video content, longpress - home screen


  • change audio stream for video content, longpress - Favorites


  • info about video or about PVR channel, longpress - PlayerDebug
  • in main menu it open settings

Default settings:
Power longpress - power menu
OK longpress - content menu

To use all described functionality:

  • copy the file “X92_keyboard” to /storage/.config/rc_keymaps/ and “rc_maps.cfg” to /storage/.config/
  • copy “keymaps.xml” to /storage/.kodi/userdata/keymaps/
  • copy empty “98-eventlircd.rules” to “/storage/.config/udev.rules.d/”
  • reboot

For all modes:
You can change the value how long it takes until Linux recognizes that you released a button. Test you remote with command ir-ctl -t 20000 where (20000 is 20 ms - minimal for X92 remote, use bigger values if remote doesn’t work after this command) and after:
Copy /usr/lib/udev/rules.d/70-input-repeat.rules to /storage/.config/udev.rules.d, and then add this line with correct value at the end (all in a single line, after the LABEL=“end” line):

ACTION==“add|change”, KERNEL==“lirc*[0-9]”, DRIVERS==“meson-ir”, RUN+="/usr/bin/ir-ctl -d $devnode -t 20000"

P.S.: If you receive some errors, try to use files above as template and replace only names and mapping or check in Notepad++ for correct EOL conversion:
Edit->EOL conversion->Unix

And also default kodi keymap for remote:
Default kodi keymap for keyboard:
Kodi keys Lircmap(not all work):


you seem to know a lot about remote configuration. When I use a remote.xml file for a better configuration of the remote can use then the KEY_“values” directly in the remote.xml file? For example, in my custom ir-keytable a binded the IR codes from the numberic pad to actions. For example 1=rewind, 2=playpause, 3=fastforward, etc. for numbers 7, 9 and 0 I want to bind with actions not included in the ir-keytable values.
7 and 9 should regulate the adjustment of the subtitles (earlier or later). 0 should be binded to start a addon.
Can I then in the remote.xml bind KEY_7 to the disired action like this <7></7> same for KEY_9 and KEY_0 should become something like <0><RunAddon(addon)></0>. I already tired that but I did put everything in the keymap.xml file according to this principle as described in the kodi wiki, but maybe this is wiki isn’t up to date anymore for leia.

My example above updated several minutes ago with possible answer on your question.
See links on default kodi keymap for remote and for keyboard in the end of my X92 message
In your case it looks like you need to use <seven></seven> in remote.xml for KEY_7 and etc.
Find similar example and use it for your case
P.S.: In Kodi 18 several buttons like <red> in keyboard mode doesn’t work. So could be non-working exceptions

Thanks! Seven, nine and zero worked to get everything as wanted. Do you know where I can find the file that translates all the KEY_actions to the usable “actions”, with other words where is written that KEY_7 equals seven? If I check the log LIRC translates KEY_7 to JumpSMS7, so that should be somewhere in a configuration file.

My post updated, see “Kodi key Lircmap”

Thanks a lot. I was already searching on github for lircmap.xml, but didn’t find it.

SoC S905 Box KIII

KIII.ZIP (517 Bytes)

1 Like

Thanks uploaded to the repo



Files: (805 Bytes)


All well for Xtreamer Whizz. I just couldn’t find anywhere instructions for making the mouse button work, so I used the mouse key for command INFO which is quite handy.

Also about the POWER command, although puts the unit to sleep, it cannot wake it up so it is kind of useless. I thing this is a hardware or CoreELEC issue. Maybe I program it for something else. Your input is welcome

RC (868 Bytes)

That’s because you are still classed as a new user because you have not browsed enough topics to raise your trust level, I have manually bumped your trust level so you should be able to post files now.

Abox A2 remoterc_maps.cfg (30 Bytes)
aboxa2.txt (194 Bytes)