NEW Repo for Remote files (Thanks to Betatester)

The rc_maps.cfg in the archive has the wrong encoding (DOS/CRLF).

Here is the correction: (891 Bytes)

Thanks, uploaded :grinning:

Hello, i’ve got a question about release/repeat delay and repeat period.
In old remote.conf I found this:

repeat_delay = 40
repeat_peroid = 39
release_delay = 121

So the question is, should I set it like this in CoreELEC to make it work like in LE 8.2?

ir-ctl -t 121000
ir-keytable -D 40 -P 39

you can set
ir-ctl -t 20000
but for delay and period you can left original one or can play with delay and period settings and check when you don’t have problem with double pressed buttons.
I use ir-keytable -D 475 -P 125 for remote mode. Your settings can be different.

Here’s my remote config with longpress buttons (thanks @boot2k3) for MXQ Pro 4K

  • Longpress home button to show video info
  • Longpress mouse button to show player debug
  • Power longpress - power menu
  • OK longpress - content menu
  • Press “APPS” button to make screenshot
  • Press “KODI” button to go back to fullscreen video

MXQ Pro 4K with longpress buttons (keyboard mode) (3.0 KB)

  • copy the file “MXQPRO4K” to /storage/.config/rc_keymaps/ and “rc_maps.cfg” to /storage/.config/
  • copy “keymaps.xml” to /storage/.kodi/userdata/keymaps/
  • copy “Lircmap.xml” to /storage/.kodi/userdata/
  • copy empty “98-eventlircd.rules” to “/storage/.config/udev.rules.d/”
  • reboot

MXQ Pro 4K without longpress buttons (remote mode) (863 Bytes)

  • copy the file “MXQPRO4K” to /storage/.config/rc_keymaps/ and “rc_maps.cfg” to /storage/.config/
  • reboot

@boot2k3 hope you don’t mind that I copied your instructions :stuck_out_tongue:


Thanks, uploaded to dropbox

Is one of the files “” or the “remote” for the M8s Pro L with the voice remote? Or is there another working one?

I don’t know, but why don’t you just try them, you can easily overwrite existing ones.

I use Coreftp lite to copy files on my boxes from my win 10 pc

I see you have asked a similar question on the Libreelec forum. You could try blue tooth, I use blue tooth in Coreelec with my headphones, you could try it.

Thank you for your answer. My solution was this one, if anyone needs it:

CoreELEC doesn’t use remote.conf

Sure? Without it, it doesnt work and when i copy it in there, it works.

CoreELEC IR remote does not use remote.conf
Maybe you’re not using CoreELEC?

I use the latest version of CoreElec for sure. But that is strange, i will test it again later. On the other hand it works now, why should i change it? I am not sure. Perhaps the IR Remote of the MeCool M8S Pro L works out of the box with CE? I did not change anything else there.

Hey - If it ain’t broke (now), don’t fix it! :thinking:

1 Like

I also have Xtreamer Whizz with Libreelec S905.arm-8.2-, but I can’t get my remote to work. I have tried with your remote.confg, but no success.
I don’t have much experience in such programing, so some help would be appreciated.
Could you help me?

you need a remote.conf file for versions before Leia

For LibreELEC questions you should really use LibreELEC forums. But the reply above should solve the question for you anyway.

Hi guys! I have a TX5 PRO with this remote:

In the earlier releases of Corelec, the three bands button showed the channel list on the left side of the screen.

Now the home button and the three bands button instead show the bar with the left time and with the stop/pause/channel list/settings.

Is it possible to have again that function from the three bar button?


my self made and working keytable for MECOOL KI PRO

I tried to download your file so I could add it, to the repo, but AVG reported a threat.