NEW Repo for Remote files (Thanks to Betatester)

Hereis my combined remote file it does X96, W95, A95X and magicsee N5
combined (2.2 KB)
rc_maps.cfg (779 Bytes)

The keys for the magicsee N5 are

table magicsee N5, type: NEC

0x40404d KEY_POWER
0x404045 KEY_MENU
0x40401a KEY_HOME
0x40400b KEY_UP
0x404010 KEY_LEFT
0x40400d KEY_ENTER
0x404011 KEY_RIGHT
0x40400e KEY_DOWN
0x404042 KEY_BACK
0x404044 KEY_CONTEXT_MENU # mouse

Polite request to all. If you create a new remote set, please add both the config file & the keymap, then zip them up. If there is a similar named one in Dropbox, just rename it.

I think I have left the dropbox so, you should be able to upload them yourselves. (I think)

I now have a nvidia shield, so I don’t spend as much time playing around as I did. :grinning:

table km8pro, type: NEC

0x0051 KEY_ESC
0x0052 KEY_1
0x0050 KEY_2
0x0010 KEY_3
0x0056 KEY_4
0x0054 KEY_5
0x0014 KEY_6
0x004e KEY_7
0x004c KEY_8
0x000c KEY_9
0x000f KEY_0
0x001a KEY_ENTER
0x000d KEY_HOME
0x0006 KEY_UP
0x005a KEY_LEFT
0x001b KEY_RIGHT
0x0016 KEY_DOWN
0x0019 KEY_MUTE
0x0059 KEY_POWER
0x0045 KEY_MENU
0x0005 KEY_BACK
0x0022 KEY_TEXT

please read my previous post. Create the files zip & upload


try uploading files to

Hi adam,
for simplification, convenience and better overview, one could also use the following command at this point.
irrecord -l
irrecord -l | paste

Thank you for your tireless work!
Best Regards

1 Like

How to use IR remote configurations which is built into coreelec (a95x)? I mean to say that when ones write image into sd card and card plug into andriod box (a95x box) and after installation where is built in remote configuration location or procedure?

Could you please also add a config for pivos xios ds, since a popular FAQ (am I allowed to link to the LE board? If not, please delete my link) on the libreelec board suggest to map the harmony remote according to this device to have a lot useable buttons and function to chose from.
I (and probably a lot others who have found the FAQ) have set up all my AMlogic devices and harmony remotes according to this FAQ and an already included build-in config would allow users to set up their harmony remotes without having to add another remote.conf.
I would love to see that, since I am planning to update from LE to CE with the first RC/stable leia build of Kodi.

I saw that post about the Pivos remote setup. Probably very useful, but above my abilities. I spent a lot of time to find a good enough alternative, and i found that if you add this device on Harmony:
MeCool Kiii Pro
It is already built into Coreelec and it has more buttons than any other of the pre-configured remotes ive found (incl Info button)

So for anyone with Harmony but not enough linux knowledge, then this might be the next best case

I’ve just found something strange on my Minix U1 box and the remote that comes with the box.

When I start it up some of the buttons dont work (menu for example). So I checked the config and looks like its configured correctly.

So I restarted like above:

systemctl stop kodi
systemctl stop eventlircd
ir-keytable -a /storage/.config/rc_maps.cfg -s rc0
systemctl start eventlircd
systemctl start kodi

And all of a sudden the menu button works again. But after a restart it is not working.

My rc_maps.cfg file reads.

meson-ir * M1_REMOTE

and /storage/.config/rc_keymaps/M1_REMOTE

# table M1, type: NEC
#0x119 KEY_ESC                  # <escape>
0x146 KEY_UP
0x147 KEY_LEFT
0x116 KEY_DOWN
0x10d KEY_HOME
0x104 KEY_MENU

So it seems the file isnt loaded on start up. Any ideas? I’m on 8.95.3

Sorry, copy/paste error. The file was actually in rc_keymaps ( have updated the post)

In that case I recommend you to use as template one of existing rc_maps.cfg and keymap file and copy/paste your buttons(to exclude EOL conversion and some other errors) in this template file and check again.
If still doesn’t work - upload your files somewhere to check what is wrong with them.

Thanks, I’ll have a go at it later (not at home at the moment).
What puzzles me a bit is that the menu button works after I run the script (stopping kodi & eventlircd and then starting again).

Sorry, where is the default configuration saved? I would like to modify the mecool one.

Cool! but unfortunately this was a bit useless for me in a Mecool Ki Pro box. The problem with the remote control of that box is with the buttons FAV, DTV and APPS, which send KEY_FAVORITE, KEY_COMPOSE and KEY_CONFIG respectively to Kodi, they are not associated with any action in Lircmap.xml and returns the code 0 (seen it in kodi.log), so the Keymap Editor addon can’t associate the buttons with an action. So I tried to add it to Lircmap.xml in /storage/userdata, but CE did not load it (maybe a bug?), I had to use Linux to mount the SYSTEM file, edit the Lircmap.xml in /usr/share/kodi/system and compress it again with mksquashfs with LZO, from that way I got the buttons to send some code.

If someone has the same problem, these are the lines I added to Lircmap.xml, under device “devinput”:


EDIT: WTF! Sorry, I finally did a clean installation of CoreElec and now I see that it does work putting the Lircmap.xml file in /storage/userdata, maybe I have done something that interfered with the file, I suspect about the remote config file in rc_keymaps, as I was trying to make the buttons work by changing the signal associated from KEY_COMPOSE/CONFIG/FAVORITE to another. However, maybe the devs can make the corrections in the built in Lircmap.xml file, changing the generic obcXXX codes if they know better than I what function to call in Kodi :slight_smile:

I’m sure it’s been said before but, here goes . . .
Always reconfirm suspected errors/bugs using a clean install of CoreELEC with only bundled addons installed before posting. It saves the devs wasting their time investigating an issue caused by not following recommended install procedures.
Good to see you got it sorted though.

Has anything changed regarding remotes lately?

Just done a clean install and dumped my 2 files into the correct folders via samba and nothing is working.

I created the files when coreelec first branched and they’ve been fine since. The only thing I can see is the guide says to put them in .config but I have .configfiles.


read the first post in this thread, it tells you where to put the files. You don’t need to create them again.

Copy alfawise_H96pp to /storage/.config/rc_keymaps

Copy rc_maps.cfg to /storage/.config


But I don’t have a .config folder.
I have a .configfiles folder.


I don’t have a configfiles folder. I think you need to tell us your device, what device tree you used.

Tell us the the exact steps you used.

So, recap, you burnt the correct img.gz file using rufus or similar, you then copied the correct device tree from the folder to the root, you then put the usb into the device, followed the initial setup, making a note of the ip address

what folders do you have in storage?