NEW Repo for Remote files (Thanks to Betatester)

I saw that post about the Pivos remote setup. Probably very useful, but above my abilities. I spent a lot of time to find a good enough alternative, and i found that if you add this device on Harmony:
MeCool Kiii Pro
It is already built into Coreelec and it has more buttons than any other of the pre-configured remotes ive found (incl Info button)

So for anyone with Harmony but not enough linux knowledge, then this might be the next best case

I’ve just found something strange on my Minix U1 box and the remote that comes with the box.

When I start it up some of the buttons dont work (menu for example). So I checked the config and looks like its configured correctly.

So I restarted like above:

systemctl stop kodi
systemctl stop eventlircd
ir-keytable -a /storage/.config/rc_maps.cfg -s rc0
systemctl start eventlircd
systemctl start kodi

And all of a sudden the menu button works again. But after a restart it is not working.

My rc_maps.cfg file reads.

meson-ir * M1_REMOTE

and /storage/.config/rc_keymaps/M1_REMOTE

# table M1, type: NEC
#0x119 KEY_ESC                  # <escape>
0x146 KEY_UP
0x147 KEY_LEFT
0x116 KEY_DOWN
0x10d KEY_HOME
0x104 KEY_MENU

So it seems the file isnt loaded on start up. Any ideas? I’m on 8.95.3

Sorry, copy/paste error. The file was actually in rc_keymaps ( have updated the post)

In that case I recommend you to use as template one of existing rc_maps.cfg and keymap file and copy/paste your buttons(to exclude EOL conversion and some other errors) in this template file and check again.
If still doesn’t work - upload your files somewhere to check what is wrong with them.

Thanks, I’ll have a go at it later (not at home at the moment).
What puzzles me a bit is that the menu button works after I run the script (stopping kodi & eventlircd and then starting again).

Sorry, where is the default configuration saved? I would like to modify the mecool one.

Cool! but unfortunately this was a bit useless for me in a Mecool Ki Pro box. The problem with the remote control of that box is with the buttons FAV, DTV and APPS, which send KEY_FAVORITE, KEY_COMPOSE and KEY_CONFIG respectively to Kodi, they are not associated with any action in Lircmap.xml and returns the code 0 (seen it in kodi.log), so the Keymap Editor addon can’t associate the buttons with an action. So I tried to add it to Lircmap.xml in /storage/userdata, but CE did not load it (maybe a bug?), I had to use Linux to mount the SYSTEM file, edit the Lircmap.xml in /usr/share/kodi/system and compress it again with mksquashfs with LZO, from that way I got the buttons to send some code.

If someone has the same problem, these are the lines I added to Lircmap.xml, under device “devinput”:


EDIT: WTF! Sorry, I finally did a clean installation of CoreElec and now I see that it does work putting the Lircmap.xml file in /storage/userdata, maybe I have done something that interfered with the file, I suspect about the remote config file in rc_keymaps, as I was trying to make the buttons work by changing the signal associated from KEY_COMPOSE/CONFIG/FAVORITE to another. However, maybe the devs can make the corrections in the built in Lircmap.xml file, changing the generic obcXXX codes if they know better than I what function to call in Kodi :slight_smile:

I’m sure it’s been said before but, here goes . . .
Always reconfirm suspected errors/bugs using a clean install of CoreELEC with only bundled addons installed before posting. It saves the devs wasting their time investigating an issue caused by not following recommended install procedures.
Good to see you got it sorted though.

Has anything changed regarding remotes lately?

Just done a clean install and dumped my 2 files into the correct folders via samba and nothing is working.

I created the files when coreelec first branched and they’ve been fine since. The only thing I can see is the guide says to put them in .config but I have .configfiles.


read the first post in this thread, it tells you where to put the files. You don’t need to create them again.

Copy alfawise_H96pp to /storage/.config/rc_keymaps

Copy rc_maps.cfg to /storage/.config


But I don’t have a .config folder.
I have a .configfiles folder.


I don’t have a configfiles folder. I think you need to tell us your device, what device tree you used.

Tell us the the exact steps you used.

So, recap, you burnt the correct img.gz file using rufus or similar, you then copied the correct device tree from the folder to the root, you then put the usb into the device, followed the initial setup, making a note of the ip address

what folders do you have in storage?

SSH access will show the folder as .config
SMB access shares the same folder as .configfiles :wink:

:blush: you learn something new everyday


I have Tanix TX5 Pro but when i install CoreELEC the remote speed is jerky at best…

In previous Kodi version it was flawless but in new Kodi version this is buggy and not only in CoreELEC but in all versions i have tried so far…

Is there a fix for this?

Thank you in advance for your help…

I just migrated from LibereEelec by backing up, doing a clean install, and restoring backup onto my Beelink MXIII Version II.

My previously created harmony / pivos config no longer works.

I had originally created custom remote.conf and remote second.conf files that I restored yet I don’t see an option in coreelec for infrared remote or even type of remote.

Any ideas?

Remote conf no longer works. There is a new method. which you will find if you search the forum. However, someone suggested I use the Mecool KIII profile on the Logitech database which works well.

Got it al sorted out. Used the MECOOL KIII PRO device on my harmony instead of PIVOS and it worked out of the box, no need to change anything else. Did have to edit a few buttons but all good now. Thanks.

Since the new version CE 8.95.6, my previous “trick” of setting up the Logitech Harmony as a MeCool KIII Pro doesn’t work anymore because they disabled out-of-the-box support for MeCool devices. It can still be enabled using SSH commands, but I’m looking for the perfect out-of-the-box solution, so I’m investigating replacing the Harmony setup of Mecool KIII Pro with one of the many variants of MCE IR remotes… A few of them work out of the box… I will see which one is the best as a replacement and I’ll report my findings… unless someone already knows the ideal MCE IR remote…

how can i revert everything back to original?