Nework Share with CoreELEC on Odroid N2

Can anyone help a newbie with connecting a network share on an Odroid N2 with CoreELEC? I have been looking for hours on Youtube, Hardkernel forum and this CoreELEC’s forum as well. Yet strangely I have found nothing on this topic in the way of “how to” or even end user experience? This doesn’t seem to make sense. Surely a multitude of users would have established a network connection? So why can’t I find anything on this topic? Am I blind? Or is there really no material what so ever?

If someone could point me to a link that would fulfil my personal deficiency here or even if they could instruct me how to do this it will make me a happy little vegimite.

BACKGROUND
I have a Synology NAS that is currently networked and shared and works fine on Windows 10 and Linux Mint. Also have Kodi networked on a Windows 10 mini PC that is using a samba share and is working fine.

Have a read of this, it helped me.

I had a similar issue setting the shares from Win10 to N2. What worked for me was adding a workgroup user on win10. While I can’t remember the exact steps, I think it was similar to what’s described in the link gregeeh provided. Only I did the N2 part from the Kodi gui rather than SSH under Add Source.

Maybe this can help you(?):
I had also difficuties to access to a simple disk plug on a windows 10 PC, like you I see no “basic tuto” for CE, between CE, LE, Kodi, informations are diluted on threads, wiki etc .

I was trying to do a dedicated ftp server when I finally found a “key” on a thread to use the SMB protocol to Windows 10: from CE instead of choosing the line “windows network SMB”, add a new line via " network location" like here use a fix IP for your server and use as server name .
Open a new “ghost” session on your PC (with a password), it helps me a lot to resolve the sharing troubles on windows since windows 7… and use this as username/password. (and verify the in coreelec plugin,that SMB parameters has the same workgroup as your PC). This finally works for me, the other preconfig (zeroconf, SMB) lines didn’t, but I didn’t try the SSH way, as a beginner it’s clearly not the easiest (but I SSH for the remote config).