Nexbox A95X B7N Failed update to NG Nightly

Just tell me the correct value. I know it’s gone on reboot as it’s a live change only. You will need to fdtput it in dtb until the default got changed.

turns the LED on.

Then please try:

mount -o rw,remount /flash
fdtput -t s /flash/dtb.img /gpioleds/sys_led linux,default-trigger default-on

Then please check if the function is same like with nightly 20200722. (same behavior on boot)

After a update you have to use fdtput again, but the fdtput cmd will start working from 20200723, before it will fail as it got changed on 0723.

Hi, I’ve tried the above and it works… LED stays on (blue)… remembers throught reboot… I did not detect any other issues. As you say the next nightly resets the change

I changed the sys_led to ‘default-on’. Please check again tomorrow with next nightly if it works correct then.

A minor cosmetic bug appears to have snuck into July 23rd’s nightly -ng build, affecting the LED behavior of the NexBox A95X-B7N. This was carried over to the builds from the 24rd and 25th.

The builds prior to July 23rd are unaffected. The July 26th nightly build should resolve this.

For now there is a workaround via SSH:

Workaround for nightly -ng builds 23, 24 and 25/07

This turns the LED blue when the unit is powered on, the LED returns to red when powered off:

echo ‘none’ > /sys/class/leds/sys_led/trigger
echo ‘default-on’ > /sys/class/leds/sys_led/trigger

This makes the changes permanent till the next update:

mount -o rw,remount /flash
fdtput -t s /flash/dtb.img /gpioleds/sys_led linux,default-trigger default-on

1 Like

So far no big issues with -ng builds. I just notice one thing and i will explain here.
If i power on the box and then power on the TV +/- 5 seconds after, a green screen will appear and then after a couple of seconds it turns really dark green and stays there.
If i power on then at same time -> no issues
If i power on the box and then the TV +/- 15 seconds after -> no issues
If i power on the tv first and then the box -> no issues

What happens, after the screen turns dark green, if you power the TV off, wait 5 seconds, and then turn the TV back on?

The power on LED for the NexBox A95X-B7N now works correctly
Many thanks to all

So i made this test, and after turn on the tv it will show the green screen and then after a couple of seconds it turns dark screen.

I am unable to replicate this on my TV’s

I have A95X with 1gb ram and 8gb, same as yours
Please, share me the link of firmware android 7.1

1 Like

Thanks. I did install these fw, and i can install CE from sd card, but cant install CE to MMC (using single boot), and key power on is not working

This firmware is for NexBox A95X B7N (SoC S905X) ONLY. It will not flash on the NexBox A95X (SoC S905).

1 Like

Could you post a picture of the remote you are using?

1 Like

Thanks. I will try it again
Here is the picture of the remote, i’m using : Capture — ImgBB and the board: IMG-1932 — ImgBB
it was working perfectly with Android 6 FW from this: 36.6 GB folder on MEGA
But when I upgrade to Android 7. a wake-up key stop woking (in Android 7 and CE10).

Yes that is the correct remote.

If the firmware above doesn’t work, try this one.

1 Like

Thanks. I flash CE 10, wake up key working from power-off when i use inject_bl301 tool (here is the log ), but the box has 2 problems:

  • I can’t install CE to MMC using single mode, Install to MMC using dual boot work well, here is the log: . I did try using dtb: gxl_p212_1g_slowemmc.dts , but same result. The log is different from your box that you has post: , but it is not a big problem.
  • suspend still not working, the box immediately re-awakens when i use the suspend mode. Suspend worked as expected with the non -ng build.
    My box is Nexbox A95X B7N (1GB/8GB) same as @Betatester , same FW 7.1 , I dont know what i’m doing wrong. Please advice

I have no idea why user do not understand this:

Install in single boot mode not possible!

No DT partition was found

I think I will remove the “protection” again that the users brick the devices…
Using option x does mean NO OFFICIAL SUPPORT!!