Nexbox A95X B7N Failed update to NG Nightly

I haven’t tried boot from internal on mine. Works fine from SD Card (or USB as you say). I’ll have a look at it this weekend.

If all else fails, to revert back to -generic, restore the firmware, then redo the CE installation.

Read before you post in a thread.

Note: This thread is meant as an informative list of what users feel currently works well. This is not a support thread. If you need help with or want to report a specific issue please either start a new thread in the appropriate location or post in the nightly thread if the issue is with a nightly build.

I’ve created a new thread and moved your unsurported method of installation here in case someone else has the same idea.

1 Like

I think you must flash a new firmware on device.
I can say, that i have also a Nexbox A95X box and have also updaeted from 9.2.3 to -NG and have the same Error.
After boot from SD-Card and install with ceemmc -x i have get also an error message with installation, but after install i can boot from nand. But i can’t make a Hard or Softreset. It’s make not a reset its boot normaly.

I can install the latest nighlty into internal memory using the comand “ceemmc -x” without any errors. But it gets stuck on nexbox boot logo. I have tried with gxl_p212_2g.dtb and gxl_p212_2g_slowemmc.dtb

Strange, i have only the 1g version and use the gxl_p212_1g.dtb. I have no idea, i can only say, that the Box runs with installed coreelec.

I had some time to test the ceemmc -x command on the NexBox A95X-B7N

CoreELEC (official) nightly_20200723 (Amlogic-ng.arm) has been successfully migrated from USB Flash Drive to eMMC with the Team CoreELEC ceemmc command line tool.

These instructions are for MS Windows 10 but can easily be modified for other environments.

INSTRUCTIONS

Step 1 can be skipped if the TV Box is already running the latest Nougat 7.1 Firmware

  1. Update to the latest NexBox A95X Nougat 7.1 Firmware
  2. With the Rufus utility, create a 2 GB bootable USB Flash Drive containing CoreELEC -ng nightly_20200723
  3. Boot the TV-Box from USB and enable SSH
  4. Create SSH tunnel from Windows 10 PC with Putty and run ceemmc -x

NOTE: I had to run ceemmc -x twice.

I noticed the first time the ceemmc command line tool only migrated the flash partition. After running the command again, both flash and storage partition were migrated.

Here is the Putty capture log: https://pastebin.com/AAT6nAjU

1 Like

The log shows storage partition was copied successful on first time already. It was only ~4MB so maybe you where thinking nothing was copied.

Nothing was migrated to storage the first time the command was executed, regardless of what the log says. Executing the command again migrated the data to storage.

This is not uncommon to me and known to happen even more frequently with LibreELEC (yes I know, different kernel and team) 7.xx’s installtointernal command line tool. It can be the reason of the JeOS sitting forever at the boot logo. The work around is to execute the command line tool again. Some boxes just work that way and need to have the command migration tool executed twice for successful migration.

1 Like

The box was with android 7.1 and then “installtointernal” since 9.0.0 or even before (i don’t remember). Never has any issue. Only this time when i tried to update to -ng builds.
This is my Putty capture log when using “ceemmc -x”: https://pastebin.com/c19NvaCg

Next week i will try some tests with flash back stock android and then flash -ng builds in dual and single boot.

I would suggest to try and execute ceemmc -x twice, without restarting the box, eq: you run it once, choose option 1 and follow the instructions. Once it says success, run ceemmc -x immediately again, without restarting the box, this time choose option 4.
Once completed, remove the installation media and reboot from within CE (power menu / reboot).

It it still doesn’t work, I would say, go ahead and re-flash the firmware. There is a link to the latest firmware in my original post.

1 Like

Thank you for you attention. But as you see in my Putty capture log, I only have 3 options.

UPDATE:

Once completed, remove the installation media and reboot from withing CE (power menu / reboot).

This fixed the issue! Before i was removing the sdcard/usb and disconnecting the power supply.
Thank you so much @Betatester

NexBox A95X-B7N

Latest nightly has an issue with the power LED: after powering on, initially the LED goes from red to blue (approx. 6 seconds) then back red. Normally the LED is constant blue when the box is running and red when the box is off.

Please try to change the LED by sysfs:
cd /sys/class/gpioleds/sys_led

there should be a file called linux,default-trigger
you can set it by:
echo 'default-on' > linux,default-trigger
or off:
echo 'none' > linux,default-trigger

I am not 100% sure about the path but it should be this one. Then report which setting is the correct one, thx.

The location doesn’t exist: https://pastebin.com/yVe3KpZd

ok checked it now:
echo 'none' > /sys/class/leds/sys_led/trigger
echo 'default-on' > /sys/class/leds/sys_led/trigger

ok. That does work for the active session. Upon reboot, the setting is lost and the light is red again. Shall we continue this as private message?

Just tell me the correct value. I know it’s gone on reboot as it’s a live change only. You will need to fdtput it in dtb until the default got changed.

turns the LED on.

Then please try:

mount -o rw,remount /flash
fdtput -t s /flash/dtb.img /gpioleds/sys_led linux,default-trigger default-on
sync
reboot

Then please check if the function is same like with nightly 20200722. (same behavior on boot)

After a update you have to use fdtput again, but the fdtput cmd will start working from 20200723, before it will fail as it got changed on 0723.

Hi, I’ve tried the above and it works… LED stays on (blue)… remembers throught reboot… I did not detect any other issues. As you say the next nightly resets the change
Thanks

About | FAQ | Terms of Service | Privacy Policy | Legal Notice