Nightly builds (NEW)

That seems to be the way with most devices.

@anon88919003 did you see my comment?
something must be different/broken in nightly builds because A52@1992MHz is working in 9.2.1

No it doesn’t work as hoped yet (I too have 4K non HDR TV) but as has been said elsewhere, HDR to SDR is an AMLogic implementation and so it is for them to come up with a more satisfactory solution.

It has been evident that the same issue exists in Android too.

So the bottom line as I see things right now is if you want HDR, you need to buy a new TV.

I personally don’t hold up much hope in AMLogic doing anything to assist.

Thank you for confirmation. Maybe it would be good to add note “This conversion didnt work for all files/formats/systems.” to the description of this option. I mean the text on the bottom of the screen which describes function. This would prevent any further confusion and not necessary questions? :slight_smile:

Load the module first:

modprobe cpufreq_ondemand

Thank you, I didnt realize this… So I compiled whole linux for two days to test it :sweat_smile: But it is very good point for other guys which would like to try it :slight_smile:

I use HDR2SDR with my N2 and my non-HDR 4K LG-TV. On my TV I defined an Expert2-picture setting,
which maximized the contrast (100%) and turn up the brightness (compared to normal SDR-view settings).
This TV-setting corrects the ‘HDR-picture is too dark on N2’ problem a little bit.

With this setting a HDR movie is not as good as a ‘real’ HDR-picture could be,
but the movie is viewable (more or less).

When viewing a HDR-movie I have to select this Expert2-setting on my TV.
With SDR-movies I use the Expert1-setting (standard profile)

1 Like

Problem with ethernet, low speed, image freeze. X96Max Plus2, Firmware CoreELEC-Amlogic-ng.arm-9.2-nightly_20200123

I have an X96Air P3 S905x3, one issue is that the after resumming
from suspend the TV screen is blank, otherwise the box seems to work okay (i.e ssh etc)
I’ve tried this on two TV’s same result, however I tried the on a PC monitor and it works fine?.

I’ve tried to capacture a log

Can this be fixed?

For some reason the box likes to boot headless if maybe the TV or receiver is off.

X96 Max 4G/64G/1G with Android X96Max_V311_P_20190722-1449 running Nightly_20200123-Odroid_N2 boots up with a strange turquoise color and use_rgb_to_yuv has no efect on it.

The box is working fine with Coreelec Stable 9.2.1 from another card with all the “dinghies” (remote, vfd, network, wifi, CEC, power-on) working except bluethooth and injected with Bl301 from the stable 9.2.1.

Any ideas?


You shouldn’t be running the N2 nighlie on that box. You need the generic ng nightlife.


Sorry for the stupid mistake … the stable image that works well on the box is the generic one and in the generic nightly 20200123 use_rgb_to_yuv brings back the red color.


How are things with s905 going?

I’m giving nightly a try and it works very well. However I am seeing some issues with 4K HEVC videos that weren’t there before. Some video’s start as a quarter sized square on the left top. Looks as if it doesn’t scale from the 1080p GUI to 4K properly. Using the arrow keys to skip forward and then backwards fixes it.
Is this issue already known and are there any workarounds available?

Also this video from the Kodi samples wiki entry is no longer playing. I’m just seeing a black screen (Not No Signal, just black screen with sound):

With the latest nightly I am getting image corruption and pixelation. If I stop the video and resume it will go away and redevelop about 15 mins later. I am using a vim3l.

Can you read this here

I noticed this issue using the Vim3L with Android TV.
Been watching Tennis via TVH Client all week and it happens using Dynamic AV Mode.
(Sorry i haven’t been using CE this week due to playback issues on one of my HD channels)

It does not happen with the VIM3.

I switched AV Mode to AUTO on my TV and the issue went away.
Edit: It came back
I’ll have to examine more.

When resuming from “Suspend” or “ShutDown”, navigation is frozen until power is manually disconnected from the device. This consequently make “Uploading the current log” impossible by the provided method.

My best guess would be that CEC is failing after resume. Can you still ssh into the device? I’d also try to use IR remote or Kore App to navigate just for testing.

Yes, I can still SSH with the device after resume. And I am using IR Remote to try and navigate.