Nightly builds

Totally lost now. Was on 9.0.2 with working mce usb ir receiver, updated to 9.0.3 it stopped working. Read about others in the same boat so I updated to nightly 20190706 to get it working. The thing autoupdated to 20190616 and now it doesn’t work again. Reverted to 20190706 and it works again but it keeps downloading an update even though i set it to manual update.

Can someone please tell me what I am supposed to be doing going forward? I want to disable the onboard IR as its range is poor and it gives me double presses, so i created a custom rc_maps.cfg as below. I have also enabled DVB drivers from the latest kernel and disabled TBS. All seems a bit messy now and I can’t get it working in the later versions

*		rc-rc6-mce	rc6_mce
#meson-ir	*		libreelec_multi

Same. I’ve tried on 3 different s905 / s905x boxes, and all have the same behaviour.
9.0.2 - mce usb works with crazycat
9.0.3 - mce usb doesn’t work
20190706 nightly - works with crazycat or media build drivers
20190716 nightly - doesn’t work.
I’m going to stick with 9.0.2 and the last nightly that works for now.

What I can’t understand is why the hell anyone would want to use an mce remote with the internal sensor in the first place. It makes no sense at all to me - if you have the remote you also have the sensor (or why buy it?), the usb sensor will generally be superior and if you’re already using an mce elsewhere it cocks that up. Hey-ho.

ah good at least I’m not the only one!! Scared of updating now as this is becoming a pain in the arse. Yeah I’ll probably go back to 9.0.2 till this is sorted.

Did you get a chance to take a look?

I’ve tried every available nightly since to check.


Tried the latest nightly (20190718) on 2 boxes:

  1. Nexbox A95X (S905) - the box wouldn’t boot. It updated normally (SYSTEM and kernel.img), rebooted and then hung on the CE start screen - no smb or ssh access. Tried several times, manually replaced files from zip, nada.
  2. Beelink mini mxiii (S905) - updated normally and rebooted; this box hung on the CE start screen for about 3 minutes, then booted into CE. My mce usb remote was working (:smile:) on crazycat drivers, so I changed to the media_build to test. On reboot the box wouldn’t start (waited upwards of 10 minutes, pulled the plug, tried again, just hung on the splash screen).

Both boxes started normally when rolled back to 20190706 nightly.

Edit: I just had another look at this…
My A95X was using media_build DVB drivers on 20190706 before I tried to update. This time I switched to crazycat first, and the 20190718 nightly boots normally. Switch back to media_build and I’m now looking at the splash screen again.
So a media_build issue…?
Happy to try / log if needed (just tell me what you want), for now I’m going back to 20190718 (latest) and crazycat drivers.

Can anyone fix this problem described here, regarding screenshot:

Hi, i’m new to using an Odroid N2. I’ve tried to get the nightly builds installed following the process up the top of this post but it doesn’t work. Can someone tell me what build to use from below. I can’t find any with the “NG” prefix.


Wait until the ng prefix builds will be available.
Or use the 0718 version from archive folder.
Or use stable build.

You are looking at tonights builds which haven’t finished processing yet.

You can get the previous NG nightly here

Thanks for that.

On the Odroid N2 the 0722 nightly throws an out of date device tree error. It waited 60 seconds and then booted. I can’t find anything not working . . . yet!

The device tress were refactored, they just need to be updated manually.

Just updated to 20190722 from 20190706 on my S912 and can confirm that bluetooth now appears in Kodi settings, so thanks for that fix.

PVR does seem to be broken though/ Tvheadend HTS{ Client and Tvheadend server are enabled but there is no TV option being displayed.

Normally upon seeing this I would disable and re-enable the PVR client and service and this would clear the issue but nothing that I do resolves the situation.

I’ll try a clean install first to ensure that nothing existing is causing the problem and post logs etc later if things persist.

This problem with PVR happened when I upgraded away from 0706 - but is probably an issue with TVH rather than CE so it maybe some time before it gets resolved.


I didn’t notice any issue with PVR in nightlies from 06 until I got to 22.

After a fresh test install I am able to configure Tvheadend successfully, so I’ll go back to the updated build and re-install TVH from scratch and see if that does the trick.

One thing that may be of worthy note is that on a fresh build, if i go to an existing addon installation from the Coreelec Nightly add-ons, even if there is no update, the update process simply re-downloads the existing one.

If I try the same thing from the updated build I always get an ‘update failed’ message.

Thats useful information. I have found this sort of behaviour in the past where the carry over of TVH setup files and dependencies breaks the new update of TVH and its almost impossible to purge whatever has gotten broken short of a fresh install. There was a major bump in the Addons with the last few nightlies and when I did my update CE went into Safe Mode. I needed to disable all of the addons and update all of them in turn in order to get things up and running - but TVH remained borked at the end of the process and thats when I rolled back to 9.0.3

Might try to do a test fresh install as well.


I went back to my original 06 build and then let it update to 22.

I initially went through the re-installation of the CE Module Drivers (in my case, for the Xbox one tuners), DVB drivers from the latest kernel which I achieved by selecting DVB drivers for TBS, requiring a reboot (which locked the box) and then after a restart, selecting the DVB drivers from the latest kernel again.

Then I uninstalled both TVH client and server but electing not to delete the settings, re-installing them again.
This did not change anything and PVR remained unavailable.

I then uninstalled them both again, this time choosing to delete settings, re-installing them again.
This time a connection was established and I simply had to configure the client addon and setup from my browser on the PC.

Gave things a full test and things are all up and running correctly again.

I have no idea what the problem was but at least there is a potential solution.

I’ve been having a similar issue, but I’m on 9.0.3 stable on my N2.

I use an external TVH 4.3-1802 server, and had some issues when I was on the nightly. Namely, I’d get no EPG at boot up. Turning on “wait for network…” fixed it.

But in recent weeks it’s returned, and it’s here on the stable version. TVH boots up with no EPG or recent channels list and no channels listed in the Channel Manager. In MyPVRGuide however, I can access my channel groups. But still no channels themselves show up if a group is selected.

If I clear guide data from the settings, the guide data reloads and I get my EPG and recent channels list back, but guess what? I lose my Channel Groups. Both from the EPG page as well as from the Group Manager.

If I reboot, the guide data’s all gone again and I need to clear the guide again to get my EPG back.

Note; this only happens on TV (not Radio served by the same TVH server), and I can access my recordings with no problem, regardless of what state the EPG is in.

This happens on all TVH client versions I’ve been able to download ( -

I’ve done the same as @Compent (clear everything, uninstall the plugin and reinstall), but still the problem persists after a reboot.

This also isn’t a skin problem, as it also occurs with JSON calls and anything that relies on it (Web UIs, Smartphone Kodi Remotes, etc.).

There’s nothing untoward in the logs that I can see, even with both PVR and EPG components turned on. There’s some sort of conflict between channels and groups, and it’s causing the TVH client to barf.

My whole TVH setup does seem to have become more unstable of later.