Nightly builds

how to upgrade from nightly to stable version?download the “xxx.tar”, put in updated folder and restart?

Download the update .tar file for the build you need, then copy the downloaded tar file to the “.update” folder then restart.

@Compent I have reuploaded the tar’s with the offending commit reverted.

Thank you very much.

I’ve just applied the reuploaded tar but unfortunately the issue remains.

I’ll see what happens with tonights build.

Update: Resolved with 0917 and working perfectly.

CoreELEC (official): nightly_20190917 (Amlogic-ng.arm)

Vim 3 Pro

No audio

(Same as previous Odroid N2 test builds )

I’ve been using Fixed Audio in system Audio settings since :

Odroid N2 Test Builds April 27th 2019

Noticed a big difference in Audio quality yesterday when i fired up the Vim 1 Pro s905x which works perfectly well with Audio settings on Best Match.

I’ve been listening to substandard audio with Fixed Audio using my Odroid n2 (Which shit itself) and replaced with the Vim 3 Pro.
Both these NG Devices have the fail to output 32,000 Hz audio using Best Match settings.
Simple SBC HDMI to Sharp Aquos TV setup.

**Connected to my NAD D 3020 Amp via Bluetooth. **
Audio Works with Best Match Settings

I quote myself from an other thread.

Tried the last 2 nightilies too, but dont boot. Tried it with different mSD, and “reboot to libreelec” app, with “Win32 Disk Iimager” instead of “Rufus”, nothing will boot on my device. I only see the bootlogo of X96. Did someone tried a full/clean flash for X96 Max?
But the strange is, LE builds booting fine. Only CE will not boot.

@Portisch any ideas? The only thing I can think of right now is to reflash original Android image and try again.

Are you using latest LE from balbes150?

If so, I think that version does some extra things with uboot and it prevents booting from CE. I had this happen to me and I had to reflash the Android image and then install CE.

Yepp tried balbes images. So you mean i have to flash the whole android fw again? Any recommends for fw, or can i just simply the custom fw from freakstab or any other via burning tool?

I recommend to flash the original firmware.

Should be able to use any firmware that is compatible, but original would be best.

I flashed this:- by using the SD card method.

My box is also X96Max 4g/32g/1gbit ethernet S905x2.

The most problem on this is that the script on the box is not auto updated. Just if you got booted a 9.2.0 or one of the nightly. Then it gets autoupdated. A reflash of Android reset the scripts to standard and a boot is maybe possible again. So I also recommend to recover the box by an Android image and start from beginning again.

I have the same box. Tried to download it, but break 2 times somewhere and must start again. The dl is very slow. Cant beleive there is no “real” mirror.
Wanted to try it with custom fw first, but have no “type a to type a cable” or adapter. So must buy it tomorrow and report back if all goes fine.

thx guys

Are you sure that doing all right?

  1. flash sdcard via rufus ng generic img.gz
  2. rename dtb_x96max_1Gbit_4Gb to dtb.img and move to root sdcard

I think so. Tried it with older rufus version, tried it with latest version, tried it with win32 disk imager, different mSDs, usb sticks.
But there is no dtb_x96max_1Gbit_4Gb file inside, ive found only g12a_s905x2_4g_1gbit.dtb which should be the correct dtb file for the x96 max 4/32.

yes, I mean it, but it need to rename to dtb.img and put into the root

g12a_s905x2_4g_1gbit.dtb is the correct dtb.

The issue is definitely caused by having balbes version of LE previously running on that box and your uboot needs to be reset by reinstalling android.

Do you have a box that has not had LE installed recently?

Ive tried CE before ive flashed balbes LE builds. Cause CE was in the last time my favourite image on EgoIggo. Ive onloy tried the other ine cause CE didnt boot. Did fctory reset in stock recovery aswell but nothing works.
And no, i dont have an other device, only my old EgoIggo. But differnt SoC.

What are you have a revision of x96 max V311 or V311R?