Nightly builds

I have an X96 max, and I tried the latest version of balbes with kodi 19. I start fine but it is very unstable. I reinstalled the sd coreelec and started without problems. But it effectively modifies the uboot and now I can’t start the box from the remote control on Android or on coreelec. Will I have to install the stock to recover the boot from the remote or is there any other solution?

CPU field displaying the correct info on all 3 devices I run. Thanks for fixing this.

Thank you to everyone that has given feedback on the cpu info change.

1 Like


I am running the nightlies and reflashed Android to get out of the stuck boot.

This system boots again but has re-introduced the green screen on my VIM3, the version of Android had been updated by Khadas and Superceleron which appears to have broken something again, I think it was bootloader related last time.

Anyone else getting this?

Thanks, E.

Yes. Until it is fully resolved you need to stick with Android version V190809.

At which point Kodi 19 will start to show up in Nightlies? on beta stage? RC stage?
Just asking to be informed


There’s no ETA on Kodi 19 right now.

@ukmark62 @hanspampel please read the following thread regarding switching distros.

Reinstalling Android is not required if your installed from SD/USB.

@Bindou HDR10+ is now displayed as HDR in nightly for past few days now.


Good news, thanks !

Ive written that i cant install 4g device_tree cause ive found out that my 4g ram version seems a fake 4g version or it has different board whatever. I cant install 4g.img, it only works with 2g version. I didnt found out what causes the problem. Is there a way to find out what version im having? It named as V311, i have the u211 recovery, but different board entries.

  • Device and
  • Product = u211
  • Board = A95X_Max
  • Board = g12a_u211_ 2g ???

Is there a command for “getprop” etc. under CE? Or is there no reading from eMMC possible?

You can open it and check what memory chips you have on the board, that will be the safest way to tell if you have a fake ram box. But if only a 2gb dtb works, it’s likely that you’ve got a fake ram box.

Ok thx. But there’s a seal outside. Don’t know exactly how the seller will deal with the redemption if its a fake box wehn i destroy the seal. But i think ive give it a shot to go safe.

If the seller has sold you fake goods, the threat of dealing with fraud charges probably outweighs the cost of dealing with a voided warranty. There’s also the question of whether a warranty is valid if the product sold is what was purchased.

Do you think it is possible to improve the speed of audio track change?

thanks friend!!:grinning::grinning::grinning::grinning:

So it seems it is a real 4gb version. Ive opened it, here the specs:

  • WiFi chip: AP6356S
  • Chip eMMC Flash: Samsung klmbg4geac 628 32GB
  • Spectek PS082-062BT RAM Chip on 4GB DDR4LP Type

Here are some pics in spoiler:


So why the hell does CE only works with 2g dtb on my device?

Whilst that question gets answered get on and use it. You will never use more than approximately 1g of RAM when running CE, so I guarantee that you will see no difference.

However the real issue here is that the plethora of cheap Android boxes makes comprehensive support impossible, not helped by the fact that each board can have multiple versions in circulation.

The only recommended hardware for CE is one of the SBC’s.


1 Like

Thanks to a user’s contribution, we now have LPCM support in the 4.9 kernel (Amlogic-ng).
Everything has been pushed, and should be available in the next nightly build. (20190929)
We were able to test it on Odroid N2 and Beelink GT-King. We have not tested it on S905X2 devices, but it should work. Please report any issues with this new feature.


  • Disable the Enable Dolby Digital (AC3) transcoding option under Audio Passthrough
  • Select the HDMI Multi Ch PCM option in Audio output device
  • Select the number of channels
  • Leave other passthrough settings as they are, the passthrough device should remain HDMI