Nightly builds

I’m booting from SD card on a KIII S905H rev c box that has 2GB of memory and typically has 1400MB free. I can’t tell you when this started for certain but I’d say it was in the last week or so. All I’ve done differently recently is mount a drive attached to my N2 upstairs into /storage. That said, this was done well before the onset of this problem.

I think I’ll install stable and check if the problem persists. If it doesn’t, then I’ll try each nightly until I find which one, if any, it is.

It might take me a few days to do this but I will post back.

If you have mapped a network drive and it becomes disconnected, then navigation can be a painfully slow process, usually requiring a reboot.

It’s as if the mapped drive is not recognised as having been disconnected, resulting in continual probing.

Thank you for this info. I think I might have solved this with your help. When I checked the drive on Windows, it came up as 38% fragmented. The drive has been used for ages and I’ve deleted lots over time. I have TV channel icons stored on the drive, so that would explain the lockups. I’ve defragged the drive and this morning I don’t lock up when I scroll thro channels

My theory is that the badly fragmented drive was causing problems akin to the disconnection you describe. I’ll be using the box later today and will post to confirm whether or not it’s fixed.

Having had time to mess, it seems that the mounted drive is the problem. I can confirm that it’s not connected with the nightlies because I still get it on 9.0.2 stable. I also need to say that my scrolling large list theory was wrong.

As far as I can tell, it seems that it manifests in playing music only. The same music plays fine if accessed thro the Kodi Plex client addon which, of course, doesn’t use the mounted drive. I have had lockups when selecting an artist and trying to play something in my library and when trying to play a track from the mounted drive in File Manager. If I access the drive as a smb share, there are no lockups. So, I’ve made my music library point to the smb share and all is well.

As far as I’m concerned that’s it but I will attempt to answer if anyone has questions.

Just installed the 10/10 nightly on LePotato with emmc and it will not boot. The blue light comes on and stays on, no signal and I cannot ssh into device. So not even sure how to go about recovery other than booting from an SD card and reinstalling, which is very fatiguing.

Interesting. Just loaded up an SD card and it is not booting from that either (used the 10/9 nightly). O did notice that a green light came on, never noticed it before, so that there are three lights lit while nothing seems to be happening.

Managed to boot from SD in an ugly way but done. Still trying to get emmc card to work.

Will this LPCM patch also work with S/PDIF, or is it just for HDMI?
Hopefully the next stable build will already have it. I wouldn’t really mind testing it myself, if my SD card reader wasn’t such a pain to remove the card (it’s pretty much stuck there), and updating to nightly once wouldn’t mean automatic updates at every new nightly release (which could break stuff somewhere down the line). As it is, I will have to stick with stable.

You can’t passthrough LPCM via SPDIF.

Oh… well, thank you for your time :slight_smile:

X96 MAX V311R is Fn-Link 6222B-SRB DDR3 is new firmware 2019-9-26!PpR3wAYT!cwZTe0bfa7QNJlQJFyiDG1vJDmt9g7YFBLpVA9wYBtw

October 14 version boot black screen Bluetooth can only search for one device, cable network card can not obtain normal IP

1 Like

I have issue with AAC audio and mp3 (stereo). There is no sound.
I don’t have problem with dts and others format. I’m using 2 channels output with HDMI and passthroutg (with ac3, dts, truehd… are enabled).

I try with the latest nightly build too and same result.

there is something that I missed ? ( I didn’t use my N2 for anime for a long time… normally I use Crunchyrol… )

I found a clip where there you can play the audio track with N2. Here the link (all of horriblesubs rip)


Do you use “Enable Dolby Digital (AC3) Transcoding” ? If not try with that option.

yes that’s on too

1 Like

Please remove the limit.

We do not limit cache sizes.

In your side the limited cache issue not exist?

I didn’t test it, but we didn’t change anything to add this limit. It’s probably an upstream (Kodi) bug.

does that fix the problem with AAC audio ?

Depends on the specific problem you are talking about, but in general yes.

I installed nightly 20191012.
I still have no sound with japanese ACC sterio audio. I’m connected with HDMI. I choose output : 2.0,
in audio passthrough they are all ON except : AC3 transcoding.

so far that’s mainly to only clip that doesn’t output sound. The source file was taken here :

what kind of tests I can do for you ?