No AV (CVBS) display, S905X A95 /S905W x96 mini + CE Leia 8.95.3/8.95.4.42: Blank screen after CE splash


#1

The CE S905X build for Leia beta 3 doesn’t seem to have AV support when run on my A95 Nexbox. HDMI is fine.

Any fixes? Which S905xx Leia builds supports AV?


CoreELEC 8.95.4.42
#2

The A95 has several versions with different CPUs/specs. It would be helpful if you can provide more info about your unit.


#3

This is the A95X Nexbox OTT TV BOX, with the red band on top left, with an S905X CPU. On the back it says A95X- B7N, 1G RAM/8G ROM.


#4

Have you tried CoreELEC 8.95.4.2 (Beta 4)?


#5

No.
So this might help? Is the AV problem on 8.95.3 a known bug?


#6

Last time I checked there was never an issue with CVBS support, but you have to set the resolution manually via SSH or using autostart.sh.


#7

Software tends to improve over time. If you are having issues, testing the latest release is a good rule of thumb.


#8

Ah…the answer I was looking for :joy:
Now can you be kind enough to provide a link/instructions for details?


#9

Yes progress is what we all assume :sunglasses:


#10

SSH to the box and try this:
echo 576cvbs > /sys/class/display/mode
or
echo 480cvbs > /sys/class/display/mode


#11

Still on 8.95.3

Unfortunately both above attempts failed: with AV connection I only get the Tv Box and CoreElec splash screens displayed, then the screen goes blank.

I saw this but for RPi, no /flash/config.txt for my S905:

Also the default in /sys/class/display/mode (via WinSCP) entry is 720p60Hz (flashed first as 1080p@60Hz, then to 720p@60Hz) on my PAL TV set, and the 720p display is fine with an HDMI cable connected.
When I switch to an RCA/AV cable and reboot, the /sys/class/display/mode entry changes from 720p60Hz to 576cvbs, but the display is only for the TV box and CoreElec splash screens: after the screen goes blank.

Of course what I am looking for is auto switch between HDMI display with an HDMI cable (and TV set display) present and AV when connected to an AV yellow port for TV display (as the RPi solution above suggests.)

So can some autostart.sh configuration similar to the RPI one above help here?


#12

Tested with 8.95.4.42, and same results.
Dark screen with AV after the TV box and CE splash logo…

So I need help.


CoreELEC 8.95.4.42
#13

Also tested x96 mini OTT TV Box 2/16 GB with 8.95.4.42…same results.

As a check Android OS on TV Box is fine on both HDMI and AV !


#14

Also tried $ echo “cvbs576” > /sys/class/display/mode to no avail.

How did you configure autostart.sh for CVBS?


#15

I just confirmed, CVBS is broken.
Do you know what was the last version where it worked?

I just re-tested it on 8.95.5 and it works. You may need to place a disp_cap file in /storage/.kodi/userdata/disp_cap with 576cvbs and 480cvbs as options.
Then use one of the commands in post #10. You may have to change the resolution in Kodi manually through a configuration file.


#16

Great, thanks. So 8.95.5 is out too.
Any links for configuration of the display_cap file, or do I just need to place the two text strings in the file via nano?

How do I change manually the Kodi resolution? By the echo command you stated?


#17

Yes, create the file with nano.
Put the resolutions on two lines like so:

480cvbs
576cvbs

Restart the box after you add the file.

One of the following commands should get you a picture again, so maybe it’ll then allow you to change the Kodi GUI resolution too.:
echo 576cvbs > /sys/class/display/mode
or
echo 480cvbs > /sys/class/display/mode

Regarding changing the Kodi GUI resolution from the config file, I’m not sure, never had to do it, but it’s saved in a file somewhere. Try to search google or Kodi forum.


#18

Followed your instructions:

  1. Installed 8.95.5 on my A95X Nexbox.
    The only change with AV boot is that I momentarily saw the arrow in the top left display (after the tvBox and CE splash) and then the screen went blank.

Previously only the tvBox and CE splash occurred.

  1. Put in the disp_cap with both entries, rebooted, and ssh’ed the 576 and 480 echo commands one at a time and rebooted to check AV display. (Each time there was a momentary flash on AV screen post typing.)

When I rebooted I got the arrow, but the screen went blank as usual. So some minimal progress !

PS. I am using Mimic not the default Estuary skin. Should that make a difference?
Will look for that Kodi GUI config file.


#19

Is there any point looking at /sys/devices/virtual/amhdmitx/amhdmitx0/display_cap ?

I googled and above file comes up. However nothing relevant in advancedsettings.xml or guisettings.xml.

Also I included all the HDMI settings plus the two cvbs settings in the /storage/.Kodi/userdata/display_cap file, but now the mouse arrow no longer shows: I get an error “check your settings…”


#20

Hello!
I managed to connect my TV box (Tanix TX3 mini L / S905v / 2GB RAM & 16 GB Rom) to the old TV (Aiwa) via AV (CVBS) cable. The system was installed on the SD card.
After installing the system and connecting the TV box via an AV cable, I also saw a splash screen with the name of the TV box, and then a blank screen.
To solve this problem, I did the following:
(if you know the IP address of your TV box, you can skip the first three points)

  1. connected the TV box via an HDMI cable to the monitor (this is necessary if you installed a new system and do not know which IP address in the local network of your TV box);
  2. сonnect the Etnernet cable to the TV box (you can also use the Wi-Fi connection) and turned on the tv box;
  3. in the system settings, I read and wrote in a notebook the IP address;
    (Now turn off the TV box, disconnect the HDMI cable and connect the AV, then turn on the TV box and again see a blank screen, but do not be upset :smiley: )
  4. I connected to the TV box via SSH protocol and wrote the following on the command line:

$ cd /.kodi/userdata
$ touch disp_cap
$ echo 576cvbs > disp_cap
$ echo 480cvbs > disp_cap

  1. Now we reboot the TV box and enjoy the achieved goal. :star_struck:

Maybe everything I wrote could have been made much easier, but it worked for me that way.
Sorry for my english, i used google translator.

My old TV and TV box with CoreElec

Best regards! Be happy!