No Disable Deinterlacing option on ng builds?

It’s causing issues on the playback of some of my media files.
In the past I always had it disabled, but with the 2 recent ng builds there doesn’t appear to be the option, and the media plays terribly as a result.

I noticed in the debug display that it seemed to think one of my 1080p AVC media files was interlaced (reported 1080i), and it was skipping a lot of frames as a result.
Seems the interlacing detection on the ng build is a little screwy too. This doesn’t happen on the latest non-ng build.
If I try to play a true 1080i media file it skips about 90% of the frames, unwatchable.

1 Like

Test with a fresh install.

I had something similar only on one piece of hardware during nightly testing prior to 9.2.5 release.
The problem box was a S905X3 on a test version the same as a Vim3L .
The Vim3L played certain problem streams with no issues.

I did a fresh install on the A95X F3 Air S905X3 which solved the problem.

I’ve tried several fresh installs to try and diagnose the problem further.
On ng builds:
1080i AVC = awful, tons of skipped frames
1080p VC1 = not good, frames clearly getting dropped but not reported in debug overlay
And occasionally, some 1080p AVC is getting detected as interlaced (1080i) and performing pretty badly, intermittent clusters of skipped frames.
On non-ng builds, with ‘disable deinterlacing’ enabled it improves matters, but then I often encounter a bug when seeking which freezes the entire system, prompting reboot.

I’ve just ordered an A95X F3 in the hope that it will handle all these problems significantly better, but according to the review on androidpctv ( 1080i AVC still skips, which is disappointing but hopefully CoreELEC has a better way of handling it.

I hope you purchased the A95X F3 AIR
The F3 may be a problem with CE

FFS. No I got the original A95X F3 model and it’s just been shipped from China.
I based my choice on the androidpctv review and specifically got this model over the Air model.

According to Shoog:

A95X F3 RGB 2/16 version Firmware 202006 Not possible to install CoreElec even with trying to reflash older version. When USB3 port is used by USB 3 hub wifi shut off after 1-3 min. In USB 2 port no problem. Box reaches 75 C even the cpu is already limited to 1700. The front vent is blocked by the display unit and there is no top vent. The aluminum heat sink ist flimsy at best but glued very strong to the chip. (not possible to replace) If you remove the display board, 2…

So in all likelihood this won’t even run CoreELEC?

I think this member got it to work.
A little confusing what he posted but i think it booted.

That was a mis-attributation to me, I only have experience of the VIM2, x96 Air and the N2. The only thing I would agree with is that these boxes can run very hot due to inadequate heatsinking, once temps hit 70C the box will suffer performance degradation and thermal throttling. X96 Air all seem to work well with CE with the proviso that they can overheat.


I’m considering ordering an A95X F3 Air and selling the A95X F3 as new on ebay.
I just want a system whereby I can play all my blu-ray format films (1080p & 1080i AVC, VC1, multi-channel PCM & DTS-HD) from my Emby media library without any issue.
After a couple hours research I assumed I’d got the right box… Very frustrating to find out it may not even work.

This is how the heatsink on my A95x F3 Air was applied.
Absolute joke.
I used Dental Floss to remove it.
I used my own heatsink ansd mods.

Can you please check you have not caused the stuttering with a settings change ?
I searched our forum and found an old post HERE

Now that you mention it, the issue with VC1 first occurred when I was doing extensive testing the other day, connected to a different display output with a non-adaptive refresh rate of 60hz. I usually have it connected to a TV which usually does update the refresh rate depending on the content, and the issue probably occurred due to my setup and those settings mentioned in the post you linked.

Anyway, I didn’t mention that I also have some other issues (occasional, unresolvable glitches in the HW decoder) with the X96 Mini that led to me seeking an upgrade.

Regarding the original A95X F3 and the Air model, I’m really struggling to understand a few things atm…

Someone in one of the threads mentioned the layout of the PCB between the 2 models are completely different and that it only has 2.4GHz wifi despite being labelled everywhere as dual band… yet both models are listed everywhere as having the same specs besides the lights / eMCP storage.
You make out like the differences are significant and had me convinced that I’d seriously screwed up, but if I can get CoreELEC installed, what’s the advantage of one over the other? Is there potentially an issue with eMCP?

In your previous post you quoted:

A95X F3 RGB 2/16 version Firmware 202006 Not possible to install CoreElec even with trying to reflash older version

So if my box comes with up-to-date firmware presumably I’m screwed?
But is it not possible to boot CoreELEC off the micro sd card? (which I currently do on my X96 Mini without issue)

Apologies for being all over the place, but such is my confusion.

You are asking for advise from someone who is not present on this thread.
Can I advise that you go back to the thread and ask your question there quoting the reference you are using, this will likely trigger a notification to the relevant person and you are more likely to get an appropriate response.


1 Like

Unbelievably, my A95X F3 arrived today - 8 day free delivery from China (wtf, right?) - and it works perfectly with CoreELEC.
All the issues with my X96 Mini are not present on this device with the latest CoreELEC release.
Unlike what previous posters said, the dual band wifi works, and I’ve had no issues yet with using the USB3 slot as someone else reported.
I didn’t try flashing onto the ROM, just flashed onto an old SD card, copied the ‘sm1_s905x3_4g’ device tree over, did the toothpick thing into the AV slot while booting and it worked!

The only thing that worried me initially was there was no sound when I tried playing my first media file. But since then it’s been working flawlessy with anything I throw at it.
And no overheating issues as yet, seems to run at a steady 54-58 degrees which seems reasonable.

Considering I didn’t expect it resolve my issues with my old device, let alone even boot, I am delighted with the results.

1 Like

Good to hear and thanks for reporting this A95X F3 works with CE

Unfortunately the issue with the audio not playing was not a one off:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.