No DTS-HD passthrough - N2+ on Newest Stable Build

Hi,
I am a new user, just installing CoreELEC on my new N2+ this morning. I have looked through the boards on how to passthrough Atmos and DTS-HD and followed all the steps to the best of my ability. I am currently successfully playing HDR and Dolby Atmos both in the Plex addon and through the regular videos folder. However when “DTS-HD capable receiver” is selected, all DTS goes silent. If I uncheck it, DTS plays fine, and DTS-HD movies give me sound, but only as DTS.
I am coming from an NVidia shield running MrMC where this was all working perfectly.

I saw an older thread where a couple of people were experiencing this same issue. Is there a trick to getting it working or an older stable build I can downgrade to?

What is your audio device? Some just don’t support DTS-HD.

Hi,

Thanks for your reponse.
I am using a Nakamichi Shockwafe 7.2. It shows DTS-HD when playing the same files through my NVidia Shield.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice