No video with 4k content

Hi all,

I seem to have problems getting 4k content properly shown. As soon as I play something that is 4k, the menu is shown (4 times 2x2) instead of the video. Then when I tab to the playback screen again I only see a black screen. I am able to see the on-screen menu when pausing the video and also hear the sound. No idea what is going wrong.

The gui is set to 1080x1920@60hz.
I already tried resetting all the resolution settings in the guisettings.xml but without any luck.

I’m using an Odroid-N2 with CoreElec build 9.2.3.
Also I already created a disinfo that can be found here: http://ix.io/2t49

Ay help would be greatly appreciated.

Did you try connecting N2 directly to TV? Tried another HDMI cable? Set HDR to SDR to Auto?

Thanks for your suggestions @Sholander. Did try to directly hook it up to the tv and other cables with the same result. Other 4k content does play on other sources without problems (when I connect my Macbook to the AVR via HDMI for example). Will try your HDR to SDR Auto suggestion later tonight.

I would try a fresh install on a spare SD-card (no special configutation, no rstauration of a backup) to eliminate cable/TV/power/… problems. This will narrow down the problem. I can play 4K on my 2 N2s and C4 without problem. GUI is 1080p@X or 2160p@X

Tried your suggestion to do a fresh install (and connected it directly to the tv @Sholander and toggled the HDR settings).
Downloaded some sample 4k content and though one of the videos did play back the other did not:

Not working:
HDR 10-bit HEVC 25.000fps
All my own 4k content (mostly HEVC mkv format)

Working:
HEVC 10-bit 23.976fps (in MKV)

No idea what is going wrong here.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice