Not automatically resizing storage partition

I have installed the last two versions of CoreELEC and for some reason after installation the storage partition has not been resized to take up the unused space on my SD card. Is there a way I can manually resize it so I have enough room to install some add on ?

Can you let us know the size of the sd card you are using ?
What hardware are you using ?
CoreELEC version ?
Take a screenshot of System / System Information / Storage

Its a 32 gig sd the hardware is a Nexbox A95X and it’s the latest stable 9.2.0 version of CoreELEC

@simian just for the record is the box an S905 or an S905x ?
What is the size of storage you have that is the problem ?
You should have at least 28gb with some addons.
Show us the screenshot or let us know.

It’s the S905X

SSH to your device and type the following commands.

touch /storage/.please_resize_me

Your device should then reboot and resize accordingly.

Thanks for the reply but
When the system reboots it says resize not permitted system already initialized. Any other ideas ?

You can try this but this is very unsupported :smiley:

systemctl stop kodi
mv /storage/.kodi /storage/.kodi_old
mv /storage/.config /storage/.config_old
mv /storage/.cache /storage/.cache_old

Thanks for the idea but would it be any different to wiping my SD and trying a fresh install which I did and when CE booted it said it was resizing the file system but when I look at storage it says the same as in the above picture.

Of course resize “as it should be done” is better than my hack above :slight_smile:

When you wipe your uSD card and format it to Fat32, what size does it have then ?
Can you copy a file bigger that 1 Gb to fresh formatted card ?
Did you try with a different burning tool and another uSD card ?

Maybe you have a fake SDcard.
Would suggest to test the card with one of the following methods, to exclude this as rootcause:

Thanks for all the suggestions. I tested the card and it is not fake. I decided to use a different card and it worked first time so I think it must have be the other SD card that has a weird issue.

The advice that Sholander gave you to test your SD Card is exactly what i was going to advise.
Not sure what you have done to confirm your SD Card is not a fake.
If you used Etcher to burn the CE image to that SD Card it would have probably failed the validation process.

Similar problem:
I have cloned microSD card 16 GB to 32 GB.
After that I have STORAGE (Ext4) partition on new microSD card the same size as the old one: 13.9 GB but I can’t resize it using MiniTool Partition Wizard - its not possible to drag/slide the triangles. Also not possible to set new sizes in both fields (Partition Size, Unallocated Space After)


touch /storage/.please_resize_me

cause the message: “resize not permitted system already initialized” after the reboot.
Any explanation why it is not possible to resize STORAGE partition?

If you don’t have access to a linux machine i would burn a bootable gparted image to an usb pen and boot from there. Then you can easily resize your uSD. I already used bootable gparted because my usb card reader was “out” and I had to use the windows laptop to resize the card.

I have completed the following procedure:

  1. CoreELEC backup of the old microSD; file copied to my Windows laptop
  2. Installed fresh CoreELEC on new microSD; copied backup to new microSD
  3. Restored CoreELEC from the backup

Good you solved it.