Occasional video stutter on 4K using S905x2 (Beelink GT Mini A)


Am running 9.2.1 on a Beelink GT Mini A (S905x2 with 4GB RAM and 1Gbps Ethernet)

1Gbps Ethernet connection back to my Linux file server, serving files using NFS (Mapped in Kodi, not fstab mounts). Have tested the network connection between the s905x2 box and the file server using iperf and it fully utilises the 1Gbps connection. (Tested in both directions)

I am encountering occasional video stuttering on playback of 4K rips. What I mean by stuttering is what looks like huge frame drops and the only way to resolve it is either to skip forward 30 seconds or press stop and then play, playback is then fine. This can happen 5 mins into a movie or some other time or not at all. It is quite random.

I have tried messing around with video cache settings but even with a large cache buffer I still get random video stuttering.

Has anyone else experienced this? And do you have any tips to resolve?

Thanks in advance for any guidance.

Known issue, will be fixed in a future update.

Ah excellent, good to know I am not doing anything wrong. :slight_smile:

Thanks very much.