Odroid N2 - no suspend mode

Dear CE community.
I am having an issue with my OD N2 CE Edition running CE 9.0.2.
I am unable to suspend the system.
When suspend command is sent, system is shutting it down immediately instead and it can be only powered back on again by power cycle.

Suspend command in KODI, SSH command in terminal gives same result and altering sleep.conf file changes nothing.

Tried with stable 9.0.3 and 9.2.0 and (official): Nightly_20191103.
Results are the same.

If you considering buying OD N2 CE Edition, know for a fact that this box doesn’t support proper suspend mode.
Credits for HK for good hardware, unfortunately it was a waste of time and money in my case as fundamental functionality is at fault.

What version CoreElec you running, mine came with 9.0.3:rofl:

Try updating to latest and the check the setting.

wakeup by CEC should be fixed soon. @Portisch fixed that, but i do not know when it will be in the nightly builds.

Its working fine for me

Do you have a sleep.conf file in Configfiles/sleep.conf.d/?

Or just try on SSH connection:
cat /storage/.config/sleep.conf.d/sleep.conf

I would love to test this, if i had any idea how to setup an on/off from my remote :rofl:

Can you use the same button for power on and off, or do you need separate, think i only have 1 free button on my remote?

Wow never knew that existed thanks, yes i just tried it and it does indeed shut the system right down.

So i am now after the same as you it seems.

[Portisch] Ok i just tried this, and system still shuts off completely ?

Is this anything to do with the BL301.BIN Inject, or am i on the wrong track?

N2 doesn’t need this, as it’s running a custom bootloader anyway.

Ah ok, well my N2 is working perfectly from CEC, suspends and wakes up as desired, but yes same as fazzieng, shuts down completely using ir suspend.

Im sure this is easily fixable, N2 is a great device and the picture and sound are unreal on CE.

Can’t really help with that as I never suspend my boxes, so I never played with this. But if “Suspend” from the power menu works, but the power button on the remote shuts down instead of suspend, I guess it can be remapped to suspend instead.

Thats the plan?. you leave your box on all the time or shut it down?.

Annoying thing is N2 has no power button lol.

My TV remote has all the kodi functions mapped to it apart from the power button. The power button turns off the TV but leaves the N2 on.
CEC is disabled.


Well its proven the N2 can sleep and resume, so must be an issue that can be corrected somewhere, but dont look at me, took me a week to get 2.1 sound working lol

Did you ignore my reply to you here? There are a few steps you need to do in order to get suspend working.

Did you not read that we already said that does not work?, CONFUSED

enemy units approaching…

No, because it’s like we’re talking about two different issues. You’re asking why the power button is not suspending, and fazzieng can’t get his N2 to suspend at all.

Ok im sure he said CEC was not a problem earlier? If that`s the case then it has to be an issue with his Tv surely as CEC is working perfect for me…