Odroid N2 test builds

I may have got it. It sometimes takes a very long time for the remote to wake up compared to what it was on my old Chromebox and an older Kodi version. I replicated the issue, took dmesg|paste and checked the logs, and the last item was that the device was recognised. I went back and tried and the remote worked. I was pushing the buttons about 10 seconds before ssh’ing in the box. Normally it takes maybe 1-2 seconds for the remote to wake up after pushing any button for the first time.

Yes it first start to connect after a button press and then after 5-10sec it works, ideal would be to auto connect in the waking process.

And now it’s not working again :crazy_face: Doesn’t wake up after waiting, and trying Connect won’t also work but just gives that input/output error. Nothing in the dmesg log, the last try after suspend is from around timestamp 2660.x on.

http://ix.io/1Nwh

Still having issues with my hfs+ drives mounting as read only following a reboot. Been experimenting with it a lot and, barring a genuine fix, figured I should let someone know what my solution has been, in case its of some help.
Before I used to schlep the drives back to my Mac and reconnect them there. Now I ssh into the N2.
I run mount -v
Note id for drive
then
fsck.hfsplus -h /dev/sdXX
Then I wait . . .
When finished I run
mount -o remount, rw
I generally recheck it with mount -v and it will show the volume STILL LOCKED and ro.
Now the weird part, to me anyway. I go and physically disconnect the drive from the N2 for about 5 minutes, then reconnect it. Going back to my computer the mount 0v will show the drive mounted rw.

If there is an easier way of doing this PLEASE tell me. So far this is the only method that “works” other then connecting the drive to my Mac and going through those fits. The rw status does stick through suspend/awake cycles.

Hi, I am getting this error after every resume from suspend or reboot.

Also coreelec sometimes seems to ignore Cancel button in some setting within it’s kodi addon . For example in Backup section >> create system and kodi backup, when I hit cancel button coreelec is doing a backup anyway, ignoring cancel command.

Using the nightly from july 1st, for the first time, my flirc will consistently disconnect / become unresponsive. Unplugging all my usb devices and plugging the flirc back in does not yield any fix. The only way to fix it Is to reboot the device. If I wait about 20 minutes or so (of inactivity) my flirc will again become unresponsive. There was absolutely no issue what so ever with my flirc until the last two nighties.

Any ideas? Could the usb ports have gone into a sleep state?

Thanks!

EDIT: I Think it may have been just low batteries after all … doh

The stable version didn’t work for me. Hangs at CoreELEC logo screen and stays. Rewritting eMMC card.

Sorry about that found a last minute problem with the website pointing to the wrong files. should be fixed soon.

For anybody wanting to switch to the new stable build from the nightly, the update file is https://github.com/CoreELEC/CoreELEC/releases/download/9.0.3/CoreELEC-Amlogic-ng.arm-9.0.3.tar

The stable build is a good option for anyone not comfortable with frequent updates to development builds.

For those who like living on the edge and help testing and providing feedback on the most recent developments, the nightly builds will continue as before.

6 Likes

Were there any USB related updates performed lately ?
I have serveral tv tuners, and some of them stop working (sundtek) after a short while with the following error in the kernel log:

Blockquote
usb 1-1.1: usbfs: USBDEVFS_CONTROL failed cmd mediasrv rqt 192 rq 6 len 1 ret -71

Until I restart the odroid, it won’t tune to the correct frequency.
It used to work correctly with older builds…

The update option for Amlogic-ng is also included in the download helper on our website, now.

1 Like

I saw this errors several times when not connected to the OTG USB port. I’m on the latest nightly and it still works for me.

Well, I cannot use the otg, as I have 4 tuners :frowning:

Maybe you can use a USB hub and power the tuners externally. I do only have one tuner and it is plugged there. I had this problems before. There were several kernel updates recently but it seems the issue is still not solved. There are discussions ongoing in the odroid forum, however, I don’t know about a final solution.

I do have a second N2 running Ubuntu and it does random restarts caused by heavy load and kernel panics I suppose. There is also a discussion ongoing about that. However, no solution neither.

just to confirm i do exactly this, 4 x dvb-t2 tuners (xbox tv tuners) running off usb 3.0 4 port powered hub, works great :-).

Is there a tracker issue, or forum discussion on the Hard Kernel site for those of us interested in tracking the status of the multichannel PCM implementation? I couldn’t fine one.

No. This is being worked on but there is nothing public what the status is.

1 Like

@anon83429610 I heard from @tobetter about a possible fix of the USB issue. As far as I understood there were updates applied to the kernel and uboot. Could you bring this (latest kernel and uboot) to Coreelec?

I’m not sure if it works but I guess it is worth a try.

https://forum.odroid.com/viewtopic.php?f=181&t=34849&start=50#p261376

I supposed to share the patch after having some report from a user and after Petitboot update. But, yes…definitely worth to try to see if it works for others as well.

EDIT:
The patches for U-boot and Kernel pushed and hope they can mitigate the issues and Petitboot update is also uploaded just now.
https://forum.odroid.com/viewtopic.php?f=182&t=33873&p=261451#p261451

Tobetter pushed it. Just need to update the packages and it might be in tomorrow’s Nightly

1 Like